Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
kerdum
Posts: 8
Registered: ‎09-15-2012
My Carrier: Rogers
Accepted Solution

Camera API crashing After Update to Build 671

Hi,

 

My app made use of the camera and then a few days ago I updated my Dev alpha device to build 671 (from 543) and my app erros out and crashes with the following output. I originally got my example from teh PhotoBomber sample. I tried to run the PhotoBomber on the new updated device and I got the following output:

 

## TIMESTAMP pid=15278290 at 757978 ms -> "server thread started"
### Server Thread: STARTED
startScreenEventThread(SUCCESS)
### PPS Thread: STARTED (10)
ERROR:: QNXPpsSubscriptionServer: QNXPpsSubscriptionServer::createObject: (13) Failed to create dir /pps/services/automation/framework

ERROR:: QNXPpsSubscriptionServer: QNXPpsSubscriptionServer::subscribe: Failed to open /pps/services/automation/framework/control?delta,notify=424:00000001


### TIMESTAMP pid=15278290 at 758168 ms -> "handle incoming events begin (1)"

### TIMESTAMP pid=15278290 at 758170 ms -> "handle incoming events end (1)"

### TIMESTAMP pid=15278290 at 758170 ms -> "waiting for events begin"

### TIMESTAMP pid=15278290 at 758171 ms -> "waiting for events end"

### TIMESTAMP pid=15278290 at 758171 ms -> "handle incoming events begin (1)"

### TIMESTAMP pid=15278290 at 758179 ms -> "handle incoming events end (1)"

### TIMESTAMP pid=15278290 at 758179 ms -> "waiting for events begin"
CamCommandHandler::S_HandleCommandProcessing: start
static void* PictureSaveHandler::S_RunSaveThread(void*) : DEBUG : save thread started
QObject::connect: Cannot connect (null)::shutterFired() to PhotoBomberApp::onShutterFired()

Process 15278290 (photobomber) terminated SIGSEGV code=1 fltno=11 ip=7807460c(/base/usr/lib/libbbcascadesmultimedia.so.1.0.0@+0x4b04) mapaddr=0001460c. ref=00000014

 Any Ideas? I dont see anyone else complaining about this issue so maybe I've missed something?

 

Thanks,

 

 

Please use plain text.
BlackBerry Development Advisor (Retired)
amarcon
Posts: 155
Registered: ‎07-16-2012
My Carrier: Bell

Re: Camera API crashing After Update to Build 671

Hi kerdum,

 

I've made some tests within 671 build, and it is working fine...

 

Its look like you have a null coming from camera:

 

Camera *camera = appPage->findChild<Camera*>("myCamera");
QObject::connect(camera, SIGNAL(shutterFired()), this, SLOT(onShutterFired()));

Can you double check this?

 

Cheers,

 

 

 

Please use plain text.
New Contributor
kerdum
Posts: 8
Registered: ‎09-15-2012
My Carrier: Rogers

Re: Camera API crashing After Update to Build 671

You are correc tthe camera was returning null

 

I seem to have solved the problem (though I'm not sure how I got both the photobomber app and my app into the same state). Here is what I did:

 

I checked around and saw this messsage in the console:

 

warning: Could not load shared library symbols for 9 libraries, e.g. libQtDeclarative.so.4.
Use the "info sharedlibrary" command to see the complete listing.
Do you need "set solib-search-path" or "set sysroot"?

 

I thought i must have somehow misconfigured my project (both projects). So just to humor myself I redownloaded the photobomber sample and it worked! So I'm just going to recreate my project. Not sure how I got them into that state.

 

I'll mark this as "Solved." If you have any theories as to what went wron let me know. Thanks for your help!

Please use plain text.