Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo
Accepted Solution

Can't deploy app to simulator 2318 ("Deployment Failed: Info: Sending request: Install and Launch")

Was (and is) working fine with the previous simulator (1673).

 

Momentics reports:

Deployment Failed: Info: Sending request: Install and Launch

Info: Action: Install and Launch

Info: Debug native: on

Info: File size: 655852

Info: Installing <app ID>

Info: Processing 655852 bytes

 

I found some instructions on using the command line tools:

 

$ ./blackberry-deploy -installApp -device 10.0.2.23 -password xxx -package ~/ndk-10.0.9-workspace/app/x86/o-g/app.bar 
Info: Sending request: Install
Info: Action: Install
Info: File size: 655852
Info: Installing ...
Info: Processing 655852 bytes

 

$ ./blackberry-deploy -launchApp -device 10.0.2.23 -password xxx -package ~/ndk-10.0.9-workspace/app/x86/o-g/app.bar
Info: Sending request: Launch
Info: Action: Launch
Info: Launching <app ID>
result::Invalid
Info: done

 

If I look at the device, I see that the app was actually not installed, though the "installApp" step reported no errors.

 

If I try to do it all in one go with both -installApp and -launchApp on the command line, I also get no errors (same output as the "installApp" step above), but the app is not installed or launched.

 

Any ideas beyond just going back to 1673?

 

 

Developer
Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo

Re: Can't deploy app to simulator 2318 ("Deployment Failed: Info: Sending request: Install and Launch")

I should note: I can telnet into the device just fine, SMB connections  to transfer files into the shared disk area on the device are fine. Target File System Navigator in Momentics also works fine.

Developer
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

16

[ Edited ]

I've got into same issues with both 1673 and 2318. Check your bar-descriptor whether it includes <author> and <authorId> elements, and their content should match your signing certificate info. I don't know whether it's the exact solution but it worked for me.

Developer
Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo

Re: 16

Thanks for the idea. Unfortunately, my author and authorId seem to be correct in the bar descriptor. :smileysad:

Developer
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: 16

Yesterday I've been doing some coding in QtCreator and default bar-descriptor that was created didn't include author and authorId elements. Tried deploying with both command line and directly from QtCreator and both failed with same error as yours.
Developer
Posts: 124
Registered: ‎01-29-2011
My Device: Z10, PlayBook
My Carrier: Koodo

Re: 16

What worked for me (finally) with the 10.1 simulator: Only allow the VM access to one CPU core (not two).

 

http://supportforums.blackberry.com/t5/Native-Development/Can-t-install-any-apps-on-simulator-10-0-1...