Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
torpesco
Posts: 121
Registered: ‎01-29-2011
My Device: Z10, PlayBook

Re: Can't install any apps on simulator 10.0.10.261

Unfortunately not. Next up, once I can spare the time, is to reinstall everything from scratch. One weird new related issue is that one of my apps fails to load on my Z10 in the same way. A new, empty "hello world" app will load on the Z10, but not the simulator. 

Contributor
xvart
Posts: 41
Registered: ‎05-30-2012
My Device: playbook developer

Re: Can't install any apps on simulator 10.0.10.261

I installed the latest simulator yesterday and I was able to load my apps to it... However, I have an orientation problem, which I could not solve (the app works as intended in a Z10 but in the simulator it is in portrait mode while the app is landscape mode so you can not see the right side of the app)...

Developer
torpesco
Posts: 121
Registered: ‎01-29-2011
My Device: Z10, PlayBook

Re: Can't install any apps on simulator 10.0.10.261

No luck with uninstalling the SDK / Momentics and re-installing. Still can't load an app onto the simulator. Listing installed apps works fine (as before).

 

Having better luck getting it onto my Z10 again, at least. Not going to help with finding and fixing the Q10 layout bug. :smileysad:

Developer
torpesco
Posts: 121
Registered: ‎01-29-2011
My Device: Z10, PlayBook

Re: Can't install any apps on simulator 10.0.10.261

First thing to check if you can't install apps onto the simulator: How many CPU cores are you allowing the VM to access? I'd been going along always changing to 2. Apparently that stopped working so well after 1673.

 

I just tried 10.1 from scratch, installing an app, changing one single setting, installing another app, etc...

 

As soon as I switched the VM from 1 core to 2, I could no longer load apps.

Developer
torpesco
Posts: 121
Registered: ‎01-29-2011
My Device: Z10, PlayBook

Re: Can't install any apps on simulator 10.0.10.261

I'd call that a work-around to a bug rather than a full solution... but now I can at least use the simulator!

Contributor
xvart
Posts: 41
Registered: ‎05-30-2012
My Device: playbook developer

Re: Can't install any apps on simulator 10.0.10.261

It has been long time but here is how mine ended: I could never got it to working but got a Dev Alpha B from the Sencha offer. Now that I finished my Sencha app, I started fixing the small ui bugs on z10...