Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
thecrazedbum
Posts: 2
Registered: ‎10-18-2012
My Device: Bold 9900

Corrupted shared library list / Do you need "set solib-search-path" or "set sysroot"?

Hi,

 

I'm trying to run the HTTP Communication Tutorial, when i build the app and send it to the simulator it loads the app but the activity indicator just spin's constantly and does not display any data. Running the debugger i get the below.

 

I've tried downloading a few sample app's which get the same errors in the debugger.

 

I've un-installed and reinstalled the SDK + Simulators thinking some dud files on install however still no success.

(Beta 3 SDK + Simulator)

 

I've read a few posts however none have given a solid solution / none have worked. Any idea's / solutions would be welcomed :smileyhappy:

 

---------------------------------------------------------------------------------------

MsgNak received - resending
Remote target is little-endian
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
[New pid 8585218 tid 2]
[New pid 8585218 tid 3]
[New pid 8585218 tid 4]
[New pid 8585218 tid 5]
[New pid 8585218 tid 6]
[New pid 8585218 tid 7]
[New pid 8585218 tid 8]
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Could not load shared library symbols for libHwEGL.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Could not load shared library symbols for 3 libraries, e.g. libegl_gallium.so.
Use the "info sharedlibrary" command to see the complete listing.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Could not load shared library symbols for libHwGLESv2.so.
Do you need "set solib-search-path" or "set sysroot"?
[New pid 8585218 tid 9]
[New pid 8585218 tid 10]
[New pid 8585218 tid 11]
[New pid 8585218 tid 12]
[New pid 8585218 tid 13]
[New pid 8585218 tid 14]
[New pid 8585218 tid 15]
[New pid 8585218 tid 16]
[New pid 8585218 tid 17]
[New pid 8585218 tid 18]
[New pid 8585218 tid 19]
[New pid 8585218 tid 20]
[New pid 8585218 tid 21]
[New pid 8585218 tid 22]
[New pid 8585218 tid 23]
[New pid 8585218 tid 24]
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Could not load shared library symbols for libqbbbearer.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Could not load shared library symbols for libqgenericbearer.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
[New pid 8585218 tid 25]
[New pid 8585218 tid 26]
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800
warning: Corrupted shared library list: 0x0 != 0x8307800

Please use plain text.