Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Debugger's warning messages

When I debug my app using NDK 2.1.0 Build id: 201209271809 on Playbook 2.1.0.1088 I get many messages like below before my app actually starts on PB:

warning: Could not load shared library symbols for libImgGLESv2.so.
Do you need "set solib-search-path" or "set sysroot"?

 

I know that indicates libraries version mismatch between what's inside NDK and what's inside Playbook. Two quesitons please:

1) Am I missing newer version of NDK or PB?

2) Is there easy fix as this brings significant delay (10-15 seconds) in starting debugging and a bit anoying when you tweak little things and have to restart the app often.

Thanks.

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Debugger's warning messages

Bump. Can Developer Advisor please take a look at this?

Please use plain text.
BlackBerry Development Advisor (Retired)
ashnazir
Posts: 17
Registered: ‎11-27-2012
My Device: Bold 9900
My Carrier: VodaFone UK

Re: Debugger's warning messages

Looking :-)

Please use plain text.
BlackBerry Development Advisor (Retired)
ashnazir
Posts: 17
Registered: ‎11-27-2012
My Device: Bold 9900
My Carrier: VodaFone UK

Re: Debugger's warning messages

I'm looking into this but one thing to note is that we do have a newer version of the NDK coming out soon and it would be worth trying it to see if you continue to have problems.
Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Debugger's warning messages

Any updates on this?

After upgrading my DA to the lates release and *not* upgrading NDK these warnings disappeared. So, I am afraid I'll get them back when I upgrade to the latest NDK. 

Please use plain text.