If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Dev alpha 10, bbm help

In your NDK Target Navigator right click on your device and SSH... No creds required.
Please use plain text.
Contributor
JimmyLord
Posts: 17
Registered: ‎07-12-2012
My Device: BB10 Alpha Device
My Carrier: none

Re: Dev alpha 10, bbm help

ok, thanks, that got me in.

 

The file is there, it's a link to libQtCore.so.4.8.4, but that should be fine.

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Dev alpha 10, bbm help

That means LD_LIBRARY_PATH is not set up correly. Try manually specify this variable in DebugConfigurations...->your app->Environment. Set it to /usr/libs/qt4/libs or whereever your Qt libs are.
Please use plain text.
Contributor
JimmyLord
Posts: 17
Registered: ‎07-12-2012
My Device: BB10 Alpha Device
My Carrier: none

Re: Dev alpha 10, bbm help

You definitely seem to be right about LD_LIBRARY_PATH not being set properly.

 

It seems no matter what I change my value to, for example:

    <env var="LD_LIBRARY_PATH" value="cccc"/>

the manifest.mf file has this line in it:

    Entry-Point: LD_LIBRARY_PATH=app/native/lib app/native/BBSliders

and it's only able to find the QtCore lib if I add it as an asset into that specific folder(app/native/lib) of the bar file... something I don't want to do.

 

I have no idea where it's getting the string "app/native/lib" from.

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: Dev alpha 10, bbm help

Go to debug configuration settings as I previously advised.
Please use plain text.
Contributor
JimmyLord
Posts: 17
Registered: ‎07-12-2012
My Device: BB10 Alpha Device
My Carrier: none

Re: Dev alpha 10, bbm help

ok, I changed my debug configuration's environment variables to include "LD_LIBRARY_PATH" set to "/usr/lib/qt4/lib" and it works, so now the manifest.mf looks like:

 

Entry-Point: LD_LIBRARY_PATH=/usr/lib/qt4/lib app/native/BBSliders

Will these debug environment settings be set with .bar files exported for release?  And any idea why LD_LIBRARY_PATH isn't being read from bar-descriptor.xml or what could be overriding it to "app/native/lib"?

 

btw, thanks for all the help so far.

Please use plain text.
Contributor
JimmyLord
Posts: 17
Registered: ‎07-12-2012
My Device: BB10 Alpha Device
My Carrier: none

Re: Dev alpha 10, bbm help

figured it out, and sorry to waste your time, although you did teach me a few things about the ide.

 

It turns out I've been building all my apps with a version of qde from bbndk 2.0.  I've been updating the SDK version in "Global QNX Settings" to the latest with each release, but never switching my taskbar shortcut to the newer ide.  Now that I'm running and building with the latest qde it's all working, i.e. the LD_LIBRARY_PATH from the bar-descriptor.xml is being correctly propagated to the manifest.mf file.  I'm actually kind of surprised that this is the first thing that's behaved incorrectly(as far as I know).

 

Thanks again.

Please use plain text.