Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
bbdevguy
Posts: 107
Registered: ‎11-19-2008
My Device: Not Specified

Re: Email Composer Not Working

Thanks, Zmey. The solution works. I didn't realize that composing email at this time does not work properly on the simulator but works on a physical Dev Alpha.

Please use plain text.
Developer
Zmey
Posts: 1,512
Registered: ‎12-18-2012
My Device: PlayBook, Z10, DAC

Re: Email Composer Not Working

Hi!

I believe I copy/pasted the URL from the document. It should be below this line:


"If you want to prepopulate the CC, BCC, subject, and the message body fields, use the following format: ...url..."

 

And the idea of using the URL was there:
http://supportforums.blackberry.com/t5/Cascades-Development/Problem-with-Invoke-email/m-p/2133669#M1...


Andrey Fidrya, @zmeyc on twitter
Please use plain text.
Developer
javayoung
Posts: 313
Registered: ‎05-31-2010
My Device: Alpha 10, Bold 9900, Storm 9530, Tour 9630, Curve 9320, Curve 8900
My Carrier: All

Re: Email Composer Not Working

I found all the content can be shown at the email composer, but after I click "Send" button, it is just changed into disable status and it doesn't send the email even waiting for long time. 

 

I already set up the email permisson in my application and I also set up my email accoung in my dev alpha device.

 

Dose someone know why the send button doesn't has response?




p(^_^)q
Good good study, day day up
Please use plain text.
Contributor
sunshining
Posts: 10
Registered: ‎03-04-2013
My Device: developer
My Carrier: developer

Re: Email Composer Not Working

hi,

may i ask you a question about a prepopulated attachment in the email?

have you ever tried add a prepopulated attachment?

mailto sames not work.

 

QString * url = new QString("mailto:address@domain.com?to=address2@domain.com&cc=address2@domain.com&subject=A%20Subject&body=That%20body&attachment=file:///assets/images/icon.png");
request.setUri(*url);

 

the image can not be prepopulated on the page?

Please use plain text.
New Contributor
SylvianDeguire
Posts: 5
Registered: ‎07-29-2013
My Device: Z10, Q10, PlayBook, Torch, Bold
My Carrier: Videotron

Re: Email Composer Not Working

Hi,

 

The bcc field seem not working at all!

 

I tried different ways, but the email composer never show them. And of course the email generated and send had never send an email with the bcc pass with the setUri function.

 

Any idea why ? Can it be for a security issue ?

 

Thanks!

Please use plain text.
Developer
dongfp0609
Posts: 42
Registered: ‎01-18-2013
My Device: 9000
My Carrier: CMCC

Re: Email Composer Not Working

I met the same problem! Somebody knows why?
Thanks
Please use plain text.