Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
AleksDef
Posts: 42
Registered: ‎05-30-2012
My Device: Simulator
My Carrier: Developer

Errors in ported project during runtime regarding libraries

Long story short, I am trying to port a project from Beta 1 to Beta 3. I got this when I was stepping over in main using the debugger:

 

MsgNak received - resending
Remote target is little-endian
warning: Corrupted shared library list: 0x0 != 0x86b7800
warning: Corrupted shared library list: 0x0 != 0x86b7800
warning: Corrupted shared library list: 0x0 != 0x86b7800
[New pid 12513392 tid 2]
[New pid 12513392 tid 3]
[New pid 12513392 tid 4]
[New pid 12513392 tid 5]
[New pid 12513392 tid 6]
[New pid 12513392 tid 7]
[New pid 12513392 tid 8]
warning: Corrupted shared library list: 0x0 != 0x86b7800
warning: Could not load shared library symbols for libHwEGL.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x86b7800
warning: Could not load shared library symbols for 3 libraries, e.g. libegl_gallium.so.
Use the "info sharedlibrary" command to see the complete listing.
Do you need "set solib-search-path" or "set sysroot"?
warning: Corrupted shared library list: 0x0 != 0x86b7800
warning: Could not load shared library symbols for libHwGLESv2.so.
Do you need "set solib-search-path" or "set sysroot"?
[New pid 12513392 tid 9]
[New pid 12513392 tid 10]
[New pid 12513392 tid 11]
[New pid 12513392 tid 12]

 I haven't even ported all of my c++ source files. I imported the QML assets and some images. I reinstalled QNX Momentics once and it made no difference. I made a template project which ran fine until I added the assets and the App class - there isn't anything special in its constructor, I actually commented everything in it.

 

Do I need to import certain additional libraries, and if so, how should I do it? If not, what should I do?

 

 

Please use plain text.