Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
Gazzi
Posts: 29
Registered: ‎03-20-2013
My Device: Z10

Export Relase Build Fails

Hi,

 

I developed a native BB10 application on QNX Momentics IDE(C++). It works fine on simulator but when I try to export relase build, it fails. Error message is only "null"(Included an screenshot) . I can't deploy my application for a week because of this problem. Also I tried to export sample projects in QNX without any change, the same error happened again. I comleted signing operation successfully(included an screenshot). 

 

Waiting for your help..

Thanks...

 

 

 

errorsigning

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook

Re: Export Relase Build Fails

please do not start multiple threads on the same issue, it's not going to help.

I would not try to export any samples as they use 'default' package names etc that may lead to problems.

Do you get 'exactly' the same when signing your app?

Please use plain text.
Contributor
Gazzi
Posts: 29
Registered: ‎03-20-2013
My Device: Z10

Re: Export Relase Build Fails

Firstly I tried  to export my new project but I couldn't that's why tried to export samples, I thought maybe I missed something in my project but the same error in sample projects. Is it important to be same package name in siging and exporting? which points should I watch out when setting package name?

 

Thanks a lot... 

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook

Re: Export Relase Build Fails

If you can build, deploy and run your app without signing that 100% means there is no problem in your code.

Package name must be unique (in the world) for the first signing. That is it. If you change something in your project then to sign it again you must increment version number and must *not* change package name.

Please use plain text.
Contributor
Gazzi
Posts: 29
Registered: ‎03-20-2013
My Device: Z10

Re: Export Relase Build Fails

[ Edited ]

The same think I am doing that you said, because I am developing and deploying app acccording to QNX help document and I said before I can build it successfully an test it on simulator but export to release build process always fails.  I always change version number if I don't, I recieve a version number error so I can understand and solve problem but after changing version number getting error null, what is null? It does not make sense. That's why I am asking this issue for a week but nobody knows, this error is special to me?? I will clear everything about SDK and simulator and reinstall them and new signing, if it doesn't work, my blackberry 10 adventure will finish.  I'm tired because of this meaningless error.

 

Thanks a lot for your help...

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook

Re: Export Relase Build Fails

Exporting a build that works on Simulator does not make sense as simulator has x86 architecture and real devices has arm. You need to choose Device-Release in targets to build, then deploy it to real device to test then export. If export is successfull then you'll get signed bar. Then deploy this signed .bar file to real device make sure this build works too then you are good to upload your app into BB World.

Please use plain text.