Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
BlackBerry Development Advisor
Posts: 15,021
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Fix for BlackBerry 10 Dev Alpha Program Has Ended issue

We have just released an update for BlackBerry 10 Dev Alpha users that corrects the "program has ended" issue.  You can update using Desktop Manager, which is available here.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 171
Registered: ‎07-19-2012
My Device: Q5, Q10, Z10, Z30, PlayBook

Re: Fix for BlackBerry 10 Dev Alpha Program Has Ended issue

I have upgraded my dev alpha to the latest 10.0.6.671 and now when try to deploy to the device get "SDK and Device Mismatch" warning saying that:

 

The application you are launching is built against a different Native SDK version (10.0.6.543) than your device version (10.0.6.671). Using a different Native SDK will cause issues during debugging. Would you like to proceed?

 

I assume this is just because of different build number and there are no functional SDK changes, is this correct?

 

warning.png

---
If you find my post helpful please "like" it and "accept as a solution"
BlackBerry Development Advisor
Posts: 15,021
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Fix for BlackBerry 10 Dev Alpha Program Has Ended issue

You are correct, it's just a warning because of the different build number.  You can safely ignore that message.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker