Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
StevenKader
Posts: 631
Registered: ‎02-03-2010
My Carrier: Rogers

Re: Gold 10.1 and support 10.0

From the release notes :  

 

"If you are developing for the BlackBerry Z10 smartphone, you need to download a target from the update site that matches the device version that's provided by your wireless service provider. You can verify the device version by opening the Settings app, tapping About, and checking the version that's listed in the OS Version field."

 

Which device target do you plan on using for release builds?


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.
Developer
ekke
Posts: 1,314
Registered: ‎04-08-2010
My Carrier: Telekom.de, O2, Vodafone

Re: Gold 10.1 and support 10.0


JaredCo wrote:

From the release notes :  

 

...

 

Which device target do you plan on using for release builds?


it doesn't matter which - if it's a target SDK from 10.0.x then it's for 10.0 API - if it's a target SDK from 10.1 then it's for 10.1 API

to debug on device you should select a target SDK matching the OS on the device

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

Open Source Enthusiast
blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner
bb10-development: http://appbus.org Twitter: @ekkescorner
Please use plain text.
Developer
StevenKader
Posts: 631
Registered: ‎02-03-2010
My Carrier: Rogers

Re: Gold 10.1 and support 10.0

So it doesn't matter if I build with 10.0.9.2318 or 10.0.10.261 ?  I wasn't sure if something built with 10.0.10.261 would work 100% on a device with 10.0.9.2318.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.
Developer
ekke
Posts: 1,314
Registered: ‎04-08-2010
My Carrier: Telekom.de, O2, Vodafone

Re: Gold 10.1 and support 10.0


JaredCo wrote:

So it doesn't matter if I build with 10.0.9.2318 or 10.0.10.261 ?  I wasn't sure if something built with 10.0.10.261 would work 100% on a device with 10.0.9.2318.


your release build will run on all 10.0 devices then (and on 10.1)

but to debug on a device you should use exactly the same as is installed - that's the reason why you canb downlaod so many target sdks for 10.0

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

Open Source Enthusiast
blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner
bb10-development: http://appbus.org Twitter: @ekkescorner
Please use plain text.
Developer
StevenKader
Posts: 631
Registered: ‎02-03-2010
My Carrier: Rogers

Re: Gold 10.1 and support 10.0

Got it....thanks.


Steven Kader at JaredCo
   Follow me on Twitter    |     Mipixi.com :  Web App for Photo Sharing
Please use plain text.