Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800
Accepted Solution

Gold sdk: deploy on simulator take 3mins for newly created project.

I just downloaded the gold sdk and faced a problem with deployment.  I create a new project and try to run it on emulator, and QDE takes 3mins to finish installing that simple app. Run it again still takes that long. Previous beta doesn't have this problem at all. Reinstalling both QDE, emulator and VMware doesn't solve problem either. My machine only take 20s in previous beta to do this. Anyone faced this problem? It really annoying to wait 3mins everytime I run app.

 

Thanks for your help :smileyhappy:

Developer
Developer
lew
Posts: 174
Registered: ‎03-05-2009
My Device: Dev Alpha

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

i think it only does that for device-release profiles? did you try with device-debug profiles?

Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

I'm talking about simulator-debug, as mentioned above.
Developer
Developer
lew
Posts: 174
Registered: ‎03-05-2009
My Device: Dev Alpha

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

my bad, completely misread your post :smileysad:

 

1) did you check your 'Upload' settings in your 'Run Configurations' ?

2) are you cleaning your project before every build? if so, then i assume it can take some time to compile...

Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

I think you misread it again. My problem is with running stage, not with building project. Even if i rebuild project, it never took more than 1min in previous beta. Gold version take 3min to complete when i choose run as BlackBerry application. That's problem. Reinstall everything, but can't help :smileysad:

Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

Look like the problem is with connection to the emulator. I monitor the deployment process and see that create bar file only took a second or two. I'm using VMware workstation 9.0. Will try with another version to check if problem still exist.
Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

OK I figured it out. The problem is my laptop is not connected to the Internet. Today I connect it via 3G network and deployment take only 5s. Wondering why IDE try to connect to internet when deploying app.
Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

Can anyone help me how to block QNX Momentic from connecting to internet each time it do a Run/Debug session? This really annoying since I don't have internet connection to my laptop(post this from my phone), and I don't understand why it need to connect to internet when it debugging?
Contributor
hieupious
Posts: 27
Registered: ‎11-14-2012
My Device: Curve 8900

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

We have no way to block QNX Momentic.It must have internet connection to validate your signing key.

Contributor
binhpv
Posts: 20
Registered: ‎10-18-2012
My Device: Cingular 8800

Re: Gold sdk: deploy on simulator take 3mins for newly created project.

It still connect even when I removed my signing key. Very frustracting.