Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 50
Registered: ‎10-09-2009
My Device: 9900
My Carrier: Bell

HelloWorldDisplay Sample app does not display the hello world?

Hi all,

I just import the HelloWorldDisplay Sample and run it in simulator.  It display the bubble without the message. 

 

 

 

Highlighted
New Developer
Posts: 3
Registered: ‎10-25-2011
My Device: Playbook
My Carrier: ATT

Re: HelloWorldDisplay Sample app does not display the hello world?

Not knowing why either. But I can see the text if it runs on my playbook device.

Developer
Posts: 50
Registered: ‎10-09-2009
My Device: 9900
My Carrier: Bell

Re: HelloWorldDisplay Sample app does not display the hello world?

So it works on the device but not the simulator?

Retired
Posts: 36
Registered: ‎10-26-2011
My Device: RIM Developer
My Carrier: Rogers

Re: HelloWorldDisplay Sample app does not display the hello world?

Hmmm. This is odd.

 

What simulator build did you try this on?

New Member
Posts: 1
Registered: ‎12-23-2011
My Device: Playbook
My Carrier: none

Re: HelloWorldDisplay Sample app does not display the hello world?

In the function render()

 

add

glEnable (GL_BLEND);

 

comment out

// glDisableClientState(GL_TEXTURE_COORD_ARRAY);

// glDisableClientState(GL_VERTEX_ARRAY);

// glDisable(GL_TEXTURE_2D);

 

and your simulator will be happy!