Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Regular Contributor
brad_qqq
Posts: 81
Registered: ‎03-27-2013
My Device: Dev Alpha C,Z10 LE
Accepted Solution

How to be compatible with 10.0 and 10.1?

Hi all,

 

My app is compatible with 10.0 and 10.1.But if I generate the device-release,which OS is the bundle for?

Is it compatible with 10.0 and 10.1?

 

Thanks.

 

brad_qqq

Developer
Zmey
Posts: 1,512
Registered: ‎12-18-2012
My Device: PlayBook, Z10, DAC

Re: How to be compatible with 10.0 and 10.1?

Hi,

 

http://supportforums.blackberry.com/t5/Cascades-Development-Knowledge/Appropriate-version-of-the-Bla...

 

If you build the app using older SDK, it should also work on newer OS'es, they are binary compatible.

I think you can even build it with new SDK and run on older OSes if you weren't using any of the new APIs.

 


Andrey Fidrya, @zmeyc on twitter
Regular Contributor
brad_qqq
Posts: 81
Registered: ‎03-27-2013
My Device: Dev Alpha C,Z10 LE

Re: How to be compatible with 10.0 and 10.1?

Thanks.

 

I have tested it.Building it with new SDK  can run in the older OS because I didn't use the new APIs.

And building with old SDK  also can run in the newer OS.

 

Thanks.

 

brad_qqq