Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10
My Carrier: Docomo

How to solve Unable to load library icui18n

[ Edited ]

Hello,
I am trying to compile a AR project on blackberry native sdk 10.1.
When I am building this project getting some errors here is my console output:

 

Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

 

Link to see clearly... http://www.developer.nokia.com/Community/Wiki/QAugmentedReality_-_Local_based_augmented_reality_comp...

 

does anyone have the same problem ?

so please help me to solve it out.......

Developer
Posts: 107
Registered: ‎06-12-2012
My Device: Dev Alpha C, Playbook
My Carrier: Loop

Re: How to solve Unable to load library icui18n

Are you using Qt Creator IDE?
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Developer
Posts: 123
Registered: ‎01-11-2013
My Device: BlackBerry z10
My Carrier: Docomo

Re: How to solve Unable to load library icui18n

No, Using QNX® Momentics® IDE for BlackBerry® 10 Native SDK
New Contributor
Posts: 6
Registered: ‎06-27-2013
My Device: BlackBerry Z10

Re: How to solve Unable to load library icui18n

I'll second it.  I'm getting that as well in Momentics for bbndk 10.1 on Linux (Debian Wheezy).  It doesn't seem to be causing any problems, but I'd still like to get rid of that warning, just in case it is causing problems that I don't know about.

New Developer
Posts: 21
Registered: ‎04-30-2013
My Device: Dev Alpha C
My Carrier: TIM

Re: How to solve Unable to load library icui18n

What is funny is that in when you click on menu "Project -> Add library -> Standard Blackberry platform library" you can choose to add this library to the project, but nothing changes.