Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Raestloz
Posts: 93
Registered: ‎02-23-2011
My Device: Z10 STL100-1
Accepted Solution

I do not have the minimum required memory, will I be able to run the SDK?

Specifically, I only have 2GB of memory, half of the required 4GB memory. Will I be able to run the SDK? I expect performance issues, but will it hamper me to the point of unusable?
BlackBerry Z10
Developer
indy2718
Posts: 36
Registered: ‎01-16-2013
My Device: Z10

Re: I do not have the minimum required memory, will I be able to run the SDK?

It would be like any piece of software.  It's unlikely the SDK will actually check the physcial memory, just use alot and they recommend 4GB or whatever.  My IDE running a C++ perspective uses 500MB.  But if you have a web browser open (450MB) you might have a lot of swapping (the hard drive used as extra memory).   The performance will depend on your hard drive speed then (SSD or 7200/5400) when all apps/os reach the 2GB system limit and thrash. 

Developer
Raestloz
Posts: 93
Registered: ‎02-23-2011
My Device: Z10 STL100-1

Re: I do not have the minimum required memory, will I be able to run the SDK?

Good to know, thanks! I was worried that the software will literally use more than 2GB of memory
BlackBerry Z10