Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Kaz32
Posts: 236
Registered: ‎11-24-2012
My Device: Blackberry 10 Dev Alpha
My Carrier: Telkomsel

Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

Hi, i'm recently installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

 

from:

https://developer.blackberry.com/cascades/download/releasenotes/

 

If you want to test your apps on a BlackBerry 10 device, you may also need to download a device target from the update site. You should download the10.0.10.261 version from the update site. When building your app for the current version of the BlackBerry 10 OS deployed on public devices (10.0.10.261), ensure that the platform selected in the BlackBerry 10 Native SDK is 10.0.9.2318.

 

Is this mean that if I want to create package.bar file for submitted to Blackberry Store, I must build the packages in BlackBerry 10 Native SDK is 10.0.9.2318?

 

And if debug build to my Dev Alpha device I'm build on Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261?

 

Thanks

Please use plain text.
Developer
borceg
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

[ Edited ]

With Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261 you build debug/release bars for Dev Alpha only.

Click little refresh button in momentics (update sdk button) and it'll find and install newer BlackBerry 10 Native SDK  10.0.9.2372 which you'll use for bar that will run on Z10 retail hardware.

Please use plain text.
Developer
Kaz32
Posts: 236
Registered: ‎11-24-2012
My Device: Blackberry 10 Dev Alpha
My Carrier: Telkomsel

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

[ Edited ]

So, I want to submit my apps to Blackberry Store.

And build with new  BlackBerry 10 Native SDK  10.0.9.2372 for Z10.

 

Will this package run on Dev Alpha Device ?, because on  store there is list of supported device, beside Z10 also Dev Alpha.

 

Can I submit 2 packages for each device? One for Z10 and one for dev Aplha?

 

Thanks

Please use plain text.
Regular Contributor
Transcendental_Mobile
Posts: 94
Registered: ‎04-07-2011
My Device: PlayBook
My Carrier: QED

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

There's no point in supporting the Dev Alpha on BlackBerry World.

 

The Dev Alpha is not a commercial device and is about to disappear.

Please use plain text.
Regular Contributor
Transcendental_Mobile
Posts: 94
Registered: ‎04-07-2011
My Device: PlayBook
My Carrier: QED

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

[ Edited ]

borceg wrote:

With Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261 you build debug/release bars for Dev Alpha only.

Click little refresh button in momentics (update sdk button) and it'll find and install newer BlackBerry 10 Native SDK  10.0.9.2372 which you'll use for bar that will run on Z10 retail hardware.


It seems odd (perhaps a constraint due to production schedule?) that the newer Z10 uses 10.0.9.xxxx while the legacy Dev Alpha uses 10.0.10.xxx which appears to be a "greater" (i.e., later) version number.

 

The Momentics IDE "Update Native SDK..." functionality currently shows three available SDKs:

 

    BlackBerry OS 10.0.10.261

    BlackBerry 10 Native SDK 10.0.9.2372

    BlackBerry 10 Dev Alpha Native SDK 10.0.9.2318

 

...Clear As Mud...

 

I don't doubt your statement, borceg, but what's your source (URL) for this information?

Please use plain text.
Developer
Kaz32
Posts: 236
Registered: ‎11-24-2012
My Device: Blackberry 10 Dev Alpha
My Carrier: Telkomsel

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

[ Edited ]

Just submitted to Blackberry Store, with 2 packages, one for Z10 and another for Dev Alpha.

 

Build with Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261 for Dev Alpha

And build with BlackBerry 10 Native SDK  10.0.9.2372 for Z10

 

Just try support that 2 device  :smileyhappy:

 

Please use plain text.
Developer
Developer
tw_
Posts: 42
Registered: ‎05-17-2012
My Device: Playbook, Dev Alpha A
My Carrier: O2

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

There is a blog article which explains the versions:

http://devblog.blackberry.com/2013/02/blackberry-10-ndk-target-updates/

 

But nevertheless I'm also confused about the SDK versions. The "Dev Alpha Native SDK 10.0.9.2318" is now gone from the update list. The only ones left are 10.0.9.2372 and 10.0.10.261 but both without the "Dev Alpha" tag in the name. According to the blog article above this means that none of the ones left is supposed to be for the Dev Alphas.

 

But I also want to keep supporting the Dev Alpha for the time being.

 

I guess I will do the same like Kaz32.

 

 

 

 

Please use plain text.
Developer
ekke
Posts: 1,461
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: Installed Blackberry 10 Dev Alpha Natvie SDK 10.0.10.261

for me it worked to use 10.0.9.2372 on Z10 and also DevAlpha

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

Open Source Enthusiast
blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner
bb10-development: http://appbus.org Twitter: @ekkescorner
Please use plain text.