Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
vishalspatil13
Posts: 14
Registered: ‎06-02-2011
My Device: Curce 9300
My Carrier: Vodafone

Is Graphics card is required for QML preview

I am facing issue on NDK Gold version: In IDE the QML preview feature is disabled and when try enable it again then I get following error:

 

"QML preview compatibility check failed. QML preview is disabled"

 

Is this issue because

1. on my machine graphics card is not there?

OR

2. this is IDE issue which is mentioned on following link

http://supportforums.blackberry.com/t5/Cascades-Development-Knowledge/No-QML-Preview-for-Some-Cascad...

 

Is it must to  have graphics card for QML preview?

 

Please use plain text.
Developer
kanaksony
Posts: 571
Registered: ‎04-11-2009
My Device: BB 10 Dev Alpha

Re: Is Graphics card is required for QML preview

Yes you need to install Graphics Card.. It is already mentioned in System Requirements... https://developer.blackberry.com/cascades/download/requirements/

Regards,
Kanak Sony
------------------------------------------------------------------------------------------
http://dodevelopnshare.wordpress.com/ | http://www.linkedin.com/profile/view?id=188131481&trk=tab_pro
Please use plain text.
New Developer
vishalspatil13
Posts: 14
Registered: ‎06-02-2011
My Device: Curce 9300
My Carrier: Vodafone

Re: Is Graphics card is required for QML preview

I think Graphics card is required for Game development. is it mandatory for normal application as well?

Please use plain text.
Developer
zezke
Posts: 1,004
Registered: ‎12-12-2010
My Device: Z10 (red Limited Edition)
My Carrier: Mobile Vikings

Re: Is Graphics card is required for QML preview

How do you mean that you don't have a graphics card? Even Intel Integrated chipsets are okay.
-------------------------------------------
BlackBerry Certified Builder for Native Application Development -- Proud member of the Belgian BlackBerry Developer group
Samples: Park in Ghent
Feeling generous? Nominate me for BB Elite member!
Please use plain text.
Developer
kanaksony
Posts: 571
Registered: ‎04-11-2009
My Device: BB 10 Dev Alpha

Re: Is Graphics card is required for QML preview

zezke is right.. your system is surely having graphics card, but may be it has a lower version.

 

Cascades require Opengl 2.0 to render QML Previews.

 

You can check the version of graphics crad installed on your system by installing a utility from - http://www.realtech-vr.com/support/download.php

 

gfx_opengl_ver.png

 

Hope it helps..

Regards,
Kanak Sony
------------------------------------------------------------------------------------------
http://dodevelopnshare.wordpress.com/ | http://www.linkedin.com/profile/view?id=188131481&trk=tab_pro
Please use plain text.