Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
farber72
Posts: 5
Registered: ‎05-26-2014
My Device: Z30

Launching fails with: listdecorators\arm\o.le-v7-g\listdecorators not found

Hello,

 

with Momentics 2.1 (Build id: 201404211616) and Simulator 10.3.0.440 I am trying to build and run the "listdecorators" example app included with the IDE.

 

Compiling it works well:

 

13:38:52 **** Incremental Build of configuration Simulator-Debug for project listdecorators ****
make -j2 Simulator-Debug
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/make -C .//translations -f Makefile update
make[1]: Entering directory `C:/Users/afarber/momentics-workspace/listdecorators/translations'
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/lupdate listdecorators.pro
Updating 'listdecorators.ts'...
Found 6 source text(s) (0 new and 6 already existing)
make[1]: Leaving directory `C:/Users/afarber/momentics-workspace/listdecorators/translations'
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/make -C .//translations -f Makefile release
make[1]: Entering directory `C:/Users/afarber/momentics-workspace/listdecorators/translations'
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/lrelease listdecorators.pro
Updating 'C:/Users/afarber/momentics-workspace/listdecorators/translations/listdecorators.qm'...
Generated 0 translation(s) (0 finished and 0 unfinished)
Ignored 6 untranslated source text(s)
make[1]: Leaving directory `C:/Users/afarber/momentics-workspace/listdecorators/translations'
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/make -C ./x86 -f Makefile debug
make[1]: Entering directory `C:/Users/afarber/momentics-workspace/listdecorators/x86'
C:/bbndk/host_10_2_0_15/win32/x86/usr/bin/make -f Makefile.Debug
make[2]: Entering directory `C:/Users/afarber/momentics-workspace/listdecorators/x86'
make[2]: Nothing to be done for `first'.
make[2]: Leaving directory `C:/Users/afarber/momentics-workspace/listdecorators/x86'
make[1]: Leaving directory `C:/Users/afarber/momentics-workspace/listdecorators/x86'

13:38:53 Build Finished (took 1s.187ms)

 

But launching fails with obscure error message:

 

Program file does not exist
C:\Users\afarber\momentics-workspace\listdecorators\arm\o.le-v7-g\listdecorators not found
C:\Users\afarber\momentics-workspace\listdecorators\arm\o.le-v7-g\listdecorators not found
C:\Users\afarber\momentics-workspace\listdecorators\arm\o.le-v7-g\listdecorators not found

 

Cleaning and rebuilding the project (tried both Debug and Release) does not help.

 

Any ideas please, what could be wrong?

 

The connection between Momentics and the Simulator VM seems to be okay (the icon is green):

 

listdecorators.png

 

Regards

Alex

Please use plain text.
Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Launching fails with: listdecorators\arm\o.le-v7-g\listdecorators not found

Not really that obscure :smileyhappy:, you have built a simulator binary (x86) and for some reason Momentics is trying to look in the ARM debug folder for the binary.

 

Check your simulator path in the bar-descriptor.xml file.

 


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Please use plain text.
New Developer
farber72
Posts: 5
Registered: ‎05-26-2014
My Device: Z30

Re: Launching fails with: listdecorators\arm\o.le-v7-g\listdecorators not found

[ Edited ]

Thanks, but I still don't get it. 

 

I haven't modified the sample app in any way.

 

The dropdown menus in Momentics are shown in the above screenshot and they point to the Simulator with a green dot.

 

The bar-descriptor.xml contains:

 

<category>core.games</category>
<configuration name="Device-Debug">
<platformArchitecture>armle-v7</platformArchitecture>
<asset path="arm/o.le-v7-g/listdecorators" entry="true" type="Qnx/Elf">listdecorators</asset>
</configuration>
<configuration name="Device-Release">
<entryPointType>Qnx/Cascades</entryPointType>
<platformArchitecture>armle-v7</platformArchitecture>
<asset path="arm/o.le-v7/listdecorators.so" entry="true" type="Qnx/Elf">listdecorators.so</asset>
</configuration>
<configuration name="Device-Profile">
<platformArchitecture>armle-v7</platformArchitecture>
<asset path="arm-p/o.le-v7-g/listdecorators" entry="true" type="Qnx/Elf">listdecorators</asset>
</configuration>
<configuration name="Simulator-Debug">
<platformArchitecture>x86</platformArchitecture>
<asset path="x86/o-g/listdecorators" entry="true" type="Qnx/Elf">listdecorators</asset>
</configuration>

 

Regards

Alex

Please use plain text.
Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Launching fails with: listdecorators\arm\o.le-v7-g\listdecorators not found

All that green dot tells you is that Momentics can connect to the simulator, nothing more.

 

The problem you have is that Momentics when trying to send the binary to the simulator is looking in the wrong directory, the bar-descriptor looks okay so this would suggest a screwed up settings or config file somewhere.

 


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Please use plain text.