Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 25
Registered: ‎01-23-2013
My Device: BB10 Simulator
My Carrier: Callmobile - T-Mobile

MapView and Simulator (in safe mode)

Hi all,

 

I am currently porting a Qt Quick project to Cascades. Sofar the results are quite good and I am satisfied with the API. For most cases, using Containers and Layouts makes me save a lot of time.

 

On the other hand, using the simulator (which I have to as I did not get any developer device...) makes it difficult for me to test the MapView widget: whenever a widget should be displayed, the application just exits without any message. Did anybody succeed in making it work with the simulator?

 

My environment:

- NDK 10.0.9.1673 (under QtCreator 2.6.81)

- Simulator 10.0.10.261 (booting with 'safe' option, as the other one does not start...)

- Linked libraries: -lbbdata -lbb -lbbcascades -lbbcascadesmaps -lGLESv1_CM -lQtLocationSubset

- MapView created in QML (similar to the MapView example)

- Process output: see below

 

Thanks and best regards!

Benoit.

 

---

MapViewPrivate::removeRenderEngine

removing the old render engine: bb::cascades::maps::BlankRenderEngine

RenderEngineManager::RenderEngineManager

RenderEngineManager::scanForPlugins()

render engine search: searching QDir( "/apps/com.example.Cascarun.testDev_le_Cascarun69d5b7a9/native/mapview-renderengine" , nameFilters = { * }, QDir::smileyfrustrated:ortFlags( Name | IgnoreCase ) , QDir::Filters( Dirs|Files|Drives|AllEntries ) )

render engine search: searching QDir( "/base/usr/lib/qt4/plugins/mapview-renderengine" , nameFilters = { * }, QDir::smileyfrustrated:ortFlags( Name | IgnoreCase ) , QDir::Filters( Dirs|Files|Drives|AllEntries ) )

render engine search: attempting to load "/base/usr/lib/qt4/plugins/mapview-renderengine/libRenderEngine3d.so"

render engine search: found TCS::RenderEngine3d

RenderEngineManager::engine( <ViewProperties altitude=10000, heading=0, lat=43.4495, lon=-80.4068, tilt=0, window=QSize(0, 0) > )

using the following render engine: TCS::RenderEngine3d

 

Developer
Posts: 419
Registered: ‎04-10-2011
My Device: Z10 LE & PlayBook

Re: MapView and Simulator (in safe mode)

I have the exact same problem :smileysad:
-----------------------------------------------------------------------------
Check out my apps in the BlackBerry World
Visit my developer blogs /dev/alopix and /home/alopix
BBM Channel: C0047B612
New Developer
Posts: 25
Registered: ‎01-23-2013
My Device: BB10 Simulator
My Carrier: Callmobile - T-Mobile

Re: MapView and Simulator (in safe mode)

Here is the corresponding bug report:

https://www.blackberry.com/jira/browse/BBTEN-331

 

Some more votes will hopefully help, kind of difficult to test an application when it crashes with the simulator...

New Developer
Posts: 25
Registered: ‎01-23-2013
My Device: BB10 Simulator
My Carrier: Callmobile - T-Mobile

Re: MapView and Simulator (in safe mode)

Small update:

- MapView is now working with the simulator under Windows (in normal mode) with the latest simulator release (1.0.1483) :smileyhappy:

- Unfortunately, it still does not work under Linux (in safe mode) and the application crashes