Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
becker666
Posts: 128
Registered: ‎04-12-2010
My Device: Storm
My Carrier: Verizon

Momentics 10.2 and different platform versions

In the old 10.1 they had a dropdown to choose the API, never used it but now I need to use that feature, mainly trying to use the 10.2 Momentics and support the older 10.1 NDK (because is not fully delivered and not all BB's out there are suppoed to have that)

 

They have a box to specify the platform, I tried that but not sure if it took or not.... I think it didn't as I managed to set the Momentics 10.2 to use the NDK 10.1 and work on a device for a while with good results, but the emulator which is 10.2 does not load the binary anymore so my suspicion is that is generating the older code

 

 Anybody managed to support different API's on Momentics 10.2????  How???

 

  Thanks

 

Please use plain text.
BlackBerry Development Advisor (Retired)
robbieDubya
Posts: 418
Registered: ‎07-18-2012
My Device: Q10
My Carrier: Bell Canada

Re: Momentics 10.2 and different platform versions

Hi,

 

10.1 compiled code should run on the 10.2 simulator...

 

I've got momentics running with 10.2 and 10.1 API installed. I go into Project | Properties | BlackBerry API Level to choose which to compile as...

 

Thanks.

--
Rob is no longer associated with BlackBerry.
Please use plain text.
New Developer
becker666
Posts: 128
Registered: ‎04-12-2010
My Device: Storm
My Carrier: Verizon

Re: Momentics 10.2 and different platform versions

Thanks ... I was wrongly setting it to the bar-descriptor XML section ... BUT  i still keep getting the lovely and obscure "Program is not a recognizable executable" message, restarted the simulator/Momentics/box , did a clean nothing ... swap to the device and everything works .... seems like a lost case and time is not on my side. I just needed to check the support for the Q10 

 

Please use plain text.
Developer
slashkyle
Posts: 820
Registered: ‎10-16-2012
My Device: Red Z10
My Carrier: Telus

Re: Momentics 10.2 and different platform versions

I have a Dev Alpha C I could test on for you if you want just let me know

Please use plain text.
BlackBerry Development Advisor (Retired)
robbieDubya
Posts: 418
Registered: ‎07-18-2012
My Device: Q10
My Carrier: Bell Canada

Re: Momentics 10.2 and different platform versions

Does a brand new empty project compile and deploy?

--
Rob is no longer associated with BlackBerry.
Please use plain text.
New Developer
becker666
Posts: 128
Registered: ‎04-12-2010
My Device: Storm
My Carrier: Verizon

Re: Momentics 10.2 and different platform versions

Will try that startup fresh and build up as that was the only way in some other occasion just needed to wrap this pronto

Thanks slash appreciate the offer managed to get somebody to run it thru
Please use plain text.
New Developer
becker666
Posts: 128
Registered: ‎04-12-2010
My Device: Storm
My Carrier: Verizon

Re: Momentics 10.2 and different platform versions

Got back to this and some with more fiddling managed to get it to load under the simulator ... this is too touchy like if u get it working don't touch it ... 

 

BUT now my 10.1 code is completely fubar, I even get a index out of range on include ../target_10_1_0_4828/qnx/user/include/qt4/QtCore/qvector.h  file and  this triggers all kinds of file:///main.qml File not found Cannot initiate global candidate selection service, corrupted shared library .... arggg

 

sounds to me likethis Momentics10.2 still not ready for prime time or users with older code try it at your own risk

 

Can I just keep using the old Momentics 10.1 to deliver code or do I need 2 versions ????

 

Please use plain text.
BlackBerry Development Advisor (Retired)
robbieDubya
Posts: 418
Registered: ‎07-18-2012
My Device: Q10
My Carrier: Bell Canada

Re: Momentics 10.2 and different platform versions

Hi,

 

That sounds really frustrating...

 

You should be able to keep on using the 10.1 version - (but it is limited and won't be updated... etc...)

--
Rob is no longer associated with BlackBerry.
Please use plain text.