Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900
My Carrier: Wind
Accepted Solution

My beta1 app won't open when compiled and run with the beta2

I have somehow successfully updated my alpha and IDE, now my only issue is that when I run my app it begins to open on the alpha but fails saying could not load library libbb.so.0, I will do some digging but if anyone has thoughts?

 

Thanks as always.

Please use plain text.
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900
My Carrier: Wind

Re: My beta1 app won't open when compiled and run with the beta2

It must be something new I am missing, as the sample apps won't even run, is there documentation on things needed to make the switch? Thanks all.

Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: My beta1 app won't open when compiled and run with the beta2

Probably rebuilding with the latest SDK will be sufficient.

Things like libbb.so have been updated, so there's a libbb.so.1 now. Relinking against the new libs would be a requirement if you aren't bundling them in the app.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900
My Carrier: Wind

Re: My beta1 app won't open when compiled and run with the beta2

Hmm, rebuilding doesn't seem to work, can I accomplish this manually? Where would the needed library/reconfiguration likely be located?

Please use plain text.
BlackBerry Development Advisor (Retired)
smacmartin
Posts: 499
Registered: ‎05-07-2012
My Device: developer
My Carrier: developer

Re: My beta1 app won't open when compiled and run with the beta2

Try creating a new project and copying your files in.

 

Stuart

Please use plain text.
Developer
borceg
Posts: 671
Registered: ‎03-21-2012
My Device: BlackBerry PlayBook 16GB
My Carrier: Vip

Re: My beta1 app won't open when compiled and run with the beta2

Hmm, strange. My beta1 app recompiles and runs fine on simulator (don't BB10 Alpha).
Create new app, import the sources (.cpp .hpp and .qml) and rearrange the new bar-descriptor file.
Please use plain text.
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900
My Carrier: Wind

Re: My beta1 app won't open when compiled and run with the beta2

I'll do that and maybe ill try it on the simulator, I've just been working with the alpha so far

 

Please use plain text.
Contributor
lvandyk
Posts: 19
Registered: ‎07-17-2012
My Device: BB 10 Alpha Device
My Carrier: Vodacom

Re: My beta1 app won't open when compiled and run with the beta2

I also had issues when upgrading to BETA 2.

 

My app would compile fine but when run in the simulator, it would crash stating: "ERROR CODE 8".

 

What I did is create a new Cascades application and just simply copied over the old files into my new project (with a name change here and there).

 

This rectified the issue.

Please use plain text.
Developer
vingilot
Posts: 224
Registered: ‎03-29-2012
My Device: 9900
My Carrier: Wind

Re: My beta1 app won't open when compiled and run with the beta2

Yes i did the same, it is unfortunate it is not backwards compatible but the issue is easily rectified, thanks all.

Please use plain text.
BlackBerry Development Advisor (Retired)
smacmartin
Posts: 499
Registered: ‎05-07-2012
My Device: developer
My Carrier: developer

Re: My beta1 app won't open when compiled and run with the beta2

For error code 8, see: http://supportforums.blackberry.com/t5/Native-Development/Use-simulator-in-QT-creator/m-p/1823253#M5...

 

Creating a new project and copying the files is overkill but will get you past some issues.  You might just need to change your library names as described in the last section of:

https://developer.blackberry.com/cascades/documentation/dev/upgrading/index.html

 

Stuart

Please use plain text.