Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
Posts: 4
Registered: ‎12-13-2012
My Device: BB10 Dev Alpha
My Carrier: AT&T

NDK for Mac OS / Java version error

I'm trying to install the latest version of the NDK (Gold) on my Mountain Lion Mac. Here is the file I downloaded:

installer-bbndk-bb10_0_09-macosx-1673-201212072306-201212091625.dmg

 

When I double click on the install-bbndk.app, nothing was happening(in mounted disk). So I decided to "Show package contents" and then run the Contents/MacOS/installer-bbndk  file. I got this error:

 

/Volumes/BlackBerry10Simulator-BB10_0_09/BlackBerry10Simulator-Installer.app/Contents/MacOS/BlackBerry10Simulator-Installer ; exit;
shikhirs-Mac-mini:~ shikhir$ /Volumes/BlackBerry10Simulator-BB10_0_09/BlackBerry10Simulator-Installer.app/Contents/MacOS/BlackBerry10Simulator-Installer ; exit;
[Deprecated] Zero G InstallerAnywhere: Forcing java.vm.version to $(java.version)-zeroG in order to preserve backward compatibility

 

What i am doing wrong?



 

 

New Member
Posts: 1
Registered: ‎02-08-2013
My Device: alpha
My Carrier: maxis

Re: NDK for Mac OS / Java version error

Try to open with "Disk Utility". Then you will see the mount drive, right-click to open and run installer.

BTW, I am facing system hang problem, especially when setting up the debug-device (discovery device).