Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Posts: 874
Registered: ‎03-20-2013
My Device: Red LE Developer Z10
My Carrier: Fido

Native SDK download painfully slow... just me?

I have always found RIM's OS downloads incredibly slow, but I'm experiencing ridiculously slow SDK download speeds from the Momentics IDE. Speedtest.net says I am hitting about 45Mb/s, but the SDKs I'm downloading are barely hitting 250-300Kb/s.


I'm trying to download the 10.1 SDK standalone installer package too, but the download is saying 9 hours to completion!


As I say, I'm used to BlackBerry servers being very slow when download an OS version or the Desktop Software (or Link), but I need this upgrade today to stay on schedule, not next week.


Is this normal?

Developer of Built for BlackBerry certified multiFEED RSS/Atom feed reader and aggregator.
Please use plain text.
Posts: 14,362
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Native SDK download painfully slow... just me?

No, you should see much higher speeds than that.  What country are you downloading from, what is your IP address and what day and time did you download?  Feel free to send the country and IP info through private message if you don't want to post that here publicly.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Posts: 107
Registered: ‎06-12-2012
My Device: Dev Alpha C, Playbook
My Carrier: Loop

Re: Native SDK download painfully slow... just me?

Dont actually go by the hours mentioned for completion. They usually don't take that long at all. But when I was updating I got much better speeds.
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Please use plain text.