Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
hdxpete
Posts: 51
Registered: ‎04-15-2013
My Device: Simulator
Accepted Solution

Noobie help

[ Edited ]

Hello,

 

Before we purchase a bb10 for testing we are looking into how long it will take us to port our game from android ndk to bb10 native sdk. having some basic issues though

 

1. currently using simulator. however eclipse not the "controller" can never seem to auto detect the simulator.

2. connecting directly to the simulator in controller SEEMS to work. I.E. says at the bottom "connected" however eclipse can never connect to the simulator to debug.

3. the password to connect to the simulator... what is the default password or where did i set the password or where can i change the password?

4. do i need to use eclipse? i have this game running on android, ios, and windows phone 8. i already have an eclipse project i don't want to muck up and iOS and wp8 allow me to create projects and reference source code not in the project folder. 

4.1. will using the blackberry Visual Studio plugin allow me to do similar? i.e. create a project and reference source code in some other random section of the HDD?

5. in the simulator what is the equivelent of the "home" button that will bring me back to the main screen?

6. how can i make the simulator appear in landscape mode? all our apps are landscape i never need portrait.

 

thank you very much from one noobie to one veteran!

 

EDIT: apparently it takes approx 10 mins for the simulator to completely warm up... now eclipse auto discovered it. seeing if i can actually debug now. any help is very appreciated.

 

EDIT2: seemed to get a default app installed however i can't seem to debug getting error below. 

Error in final launch sequence
Cannot prepare and download the binary
Deployment Failed: Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: Debug native: on
Info: File size: 35590
Info: Installing

Please use plain text.
New Developer
hdxpete
Posts: 51
Registered: ‎04-15-2013
My Device: Simulator

Re: Noobie help

Can anyone help get a proper debugging environment setup? i have followed all the documentation here
http://developer.blackberry.com/native/documentation/bb10/com.qnx.doc.native_sdk.quickstart/topic/se...
however i am unable to debug.

Also how can i compile source code outside the "src" folder? or do i HAVE to copy the source files into the src folder?
Please use plain text.
Developer
MasterOfBinary
Posts: 29
Registered: ‎05-05-2012
My Device: PB 32

Re: Noobie help

3. There shouldn't be a default password. You can set one from the simulator, by going to "Settings", choosing "Security and Privacy", and "Device Password".

4. I'm pretty sure you can make your own makefiles that basically just use qcc instead of gcc to compile. There might be sample makefiles, I'm not very familiar with that though.

4.1. I'm sure you can, since Visual Studio can. I haven't tested this, but I think if you choose to add an existing item to the project, there's an option to just add a link.

5. Click on the black part on bottom of the screen, and swipe up. You can find your apps by swiping to the left.

6. I don't know.

 

The link between the simulator and Momentics can be sketchy sometimes. I can't help too much with that, except to say you should make sure the simulator-debug configuration is active, maybe try right-clicking your project and choose "Run as->Run configurations", make sure simulator-debug is selected there too, and your target simulator as well. Click Run.

 

As far as adding links in Momentics, you can definitely do that as well. Right-click your src directory and choose "Import", "General->Filesystem", pick your directory and files, click "Advanced", and "Create links in workspace". Pick the options there that suit you.

Please use plain text.
Developer
MasterOfBinary
Posts: 29
Registered: ‎05-05-2012
My Device: PB 32

Re: Noobie help


hdxpete wrote:
Can anyone help get a proper debugging environment setup? i have followed all the documentation here
http://developer.blackberry.com/native/documentation/bb10/com.qnx.doc.native_sdk.quickstart/topic/se...
however i am unable to debug.

Also how can i compile source code outside the "src" folder? or do i HAVE to copy the source files into the src folder?

You're still getting the same error you mentioned in the first post?

Please use plain text.
New Developer
hdxpete
Posts: 51
Registered: ‎04-15-2013
My Device: Simulator

Re: Noobie help

MasterOfBinary,

 

Thanks a bunch. thanks to you a couple other people on the forum. we were able to some some portion of our code running in the simulator. (well enough to know we got a proper GL handle and we're creating textures properly)

 

however at least for us the simulator is just way too slow. (we were getting around 1 fps if that) so we are awaiting a real device.

 

thanks again ^_^

Please use plain text.