Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
PJDavis1970
Posts: 44
Registered: ‎01-22-2013
My Device: Z10, Q10, Z10 Alpha
My Carrier: None

OS 10 version confusion

Hi,

 

I have been developing for the BB10  Dev Alpha B phone with an sdk version 10.0.9.2318.

 

I received a release phone today which I am trying to test my software on.  The problem is the phone is reporting to have OS version 10.0.9.348 on it and reports no software updates available.

 

However on the Dev Alpha phone it reports I can update to version 10.9.10.35

 

I cannot test my software from the sdk on the new phone because the only sdk versions I have are 

 

10.0.9.2318 or Dev Alpha sdk 10.0.10.261.

 

Could someone clear this up for me please about what sdk I need to be able to develop for new phone

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: OS 10 version confusion

>I cannot test my software from the sdk on the new phone

why exactly you can't? it does not allow you to deploy your app to your new phone?

Please use plain text.
Contributor
PJDavis1970
Posts: 44
Registered: ‎01-22-2013
My Device: Z10, Q10, Z10 Alpha
My Carrier: None

Re: OS 10 version confusion

As stated in my original post. I cannot debug the app on the device because eclipse complains about different versions
Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: OS 10 version confusion

Usually you can click 'Proceed' and ignore Eclipse's warning... Do you have that option?

Please use plain text.
Contributor
PJDavis1970
Posts: 44
Registered: ‎01-22-2013
My Device: Z10, Q10, Z10 Alpha
My Carrier: None

Re: OS 10 version confusion

Hi. I have reinstalled the sdk with all latest updates and I am now getting option to proceed. Not sure why this was not available before. Thanks for help
Please use plain text.
Contributor
PJDavis1970
Posts: 44
Registered: ‎01-22-2013
My Device: Z10, Q10, Z10 Alpha
My Carrier: None

Re: OS 10 version confusion

Well I am still having issues.

 

QNX Momentics IDE -

 

Blackberry 10 Native SDK 10.0.9.2318  : reports to be latest

& Blackberry 10 Dev Alpha Native SDK 10.0.10.261

 

Devices

 

Z10 release device4 :  OS version 10.0.9.348 : reports to be latest

Z10 Dev Alpha B device : OS Version 10.9.10.35 : reports to be latest

 

I cannot get my software to run on these devices anymore.  I Get warning in IDE about version differences and I select continue.  My software starts to run but I get an error in IDe of

 

warning: .dynamic section for "C:\\bbndk\\target_10_0_9_2318\\qnx6\\armle-v7\\usr\\lib/libbbcascades.so.1" is not at the expected address (wrong library or version mismatch?)

 

And software hangs.

 

I need to resolve this asap as I am under a tight deadline to produce something for my company and at the moment I am gettign nowhere.

 

Thanks for any help

 

Please use plain text.
Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook
My Carrier: x

Re: OS 10 version confusion

>warning: .dynamic section for "C:\\bbndk\\target_10_0_9_2318\\qnx6\\armle-v7\\usr\\lib/libbbcascades.so.1" is not at the expected address (wrong library or version mismatch?)

This is safe to ignore.

Unfortunately I don't believe lots of people here have real BB10 devices so we can't help -(

Try using command line tools to deploy-start-debug your app on real device but I don't believe it'll work either.

Your best help would be RIM who is porbably busy now Jamming in Amsterdam.

Please use plain text.