Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
misugijunz
Posts: 24
Registered: ‎12-27-2011
My Device: Torch 9810 | PlayBook
Accepted Solution

Ported QtQuick App can't play sound on playbook + any other problems

Hi,

 

I've successfully ported an application based on qtquick running on BB10. My long lasting problem is that my apps can't play the .wav sound. It was using the QtMobility on symbian. I'm looking for a replacement and trying to adapt with open AL example in BlackBerry Github but no hope.

 

Here is the source code: https://gist.github.com/fe1fcbbb6753bb7ff06b

 

I'm binding the audio to the qtquick qml file with the setcontextproperty method. I checked with console.log() that it is called.

 

I wonder the problem between the file location or the method isn't called.

 

my sounds is under directory

qml/rod/sounds/ from root.

 

I'm also finding I can't see any output of qDebug.

 

I'm using the QtCreator for PlayBook. I wonder if I can use the momentics?

 

Thanks for help. I'm expecting to release my app before the release of BB10

Contributor
misugijunz
Posts: 24
Registered: ‎12-27-2011
My Device: Torch 9810 | PlayBook

Re: Ported QtQuick App can't play sound on playbook + any other problems

I've my solution for this problem. I opened my .pro via momentics IDE. I clicked mouse right to the project > configure > add libraries > check list all required libs > then follow the cheatsheet provided to alter the .pro files. Simple and it works.