Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
MichalKozminski
Posts: 36
Registered: ‎07-05-2012
My Device: 9900 & dev alpha
My Carrier: Play - P4

Porting and using library

Hi,

I'm trying to port this library: http://toxygen.net/libgadu/files/libgadu-1.11.2.tar.gz and use it on Blackberry Dev Alpha. So I done step by step as it is written here : https://developer.blackberry.com/native/documentation/porting_overview_1970891_11.html (Use the GNU Autotools). After I run make I get this: 


Making all in src
  CCLD   libgadu.la
libtool: link: : unknown library version type `qnx'
libtool: link: See the libtool documentation for more information.
libtool: link: Fatal configuration error.
make[2]: *** [libgadu.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


How can I fix this issue?

Please use plain text.
New Developer
igoris
Posts: 2
Registered: ‎04-02-2012
My Device: Playbook
My Carrier: Kyivstar

Re: Porting and using library

Which version of autotools do you use?

 

Support of QNX version scheme was added in 2.1

Please use plain text.