Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
ingvar_e
Posts: 551
Registered: ‎10-31-2009
My Device: Torch 9800, Bold 9700
My Carrier: Movistar, Telenor
Accepted Solution

Problems installing native sdk

 - Downloaded the Gold Native SDK

 - Installed on E:\BBndk

 - Started

 

Got "Cannot start Java VM"  Recognized that problem so I  changed the config parameter from

 - Xmx1024   to  -Xmx512

 

Eclipse starts ok. Get message:

 

"No SDK can be found. Install a SDK to enable Momentics features"

 

Go to "Software updates" to see if I can download something

 

"No available sites"

 

My guess is that some path is hard coded in the install program.

Well I can not use my C-drive, it is an SSD-disk solely for  Windows

 

I am running Windows XP on a 4 GB machine. No problem running Eclipse with pre 10 Java environment, done that for several years

If everything seems to be under control, you're just not driving fast enough
-Mario Andretti-
Please use plain text.
New Contributor
thebrave
Posts: 7
Registered: ‎02-01-2013
My Device: Developer - DevAlpha A & PlayBook
My Carrier: B&You - FR

Re: Problems installing native sdk

I installed all SDKs (including gold) on D:\ drive, never had problem.

The update feature doesn't work that way use "Update Native SDK" instead.

 

Do you launch Momentics using bbndk.bat ?

Please use plain text.
Developer
ingvar_e
Posts: 551
Registered: ‎10-31-2009
My Device: Torch 9800, Bold 9700
My Carrier: Movistar, Telenor

Re: Problems installing native sdk

Thanks "thebrave".

Running an update. To start I use whaqt the install offered and that is a link directly to "qde.exe". Is the "bat" a better  choice?

If everything seems to be under control, you're just not driving fast enough
-Mario Andretti-
Please use plain text.
New Contributor
thebrave
Posts: 7
Registered: ‎02-01-2013
My Device: Developer - DevAlpha A & PlayBook
My Carrier: B&You - FR

Re: Problems installing native sdk

Yes, the bat file ensure the JVM and the IDE receive the correct parameters.

 

Launching qde.exe works on my machine. But it's the first time ever i'm doing that,  and I never got any probleme on two machines.

 

If you keep having problems, my machines all have 8GB or RAM, that's maybe also that.

Also, do enable virtual memory on you machine. It won't work without.

Please use plain text.
Developer
ingvar_e
Posts: 551
Registered: ‎10-31-2009
My Device: Torch 9800, Bold 9700
My Carrier: Movistar, Telenor

Re: Problems installing native sdk

I did a reinstall on my E-drive and used the  bat file instead. After changing the  qde.ini file

to  -Xmx768M  it started ok.

 

Batfile did the trick

 

I am running XP on 4GB and 15GB virtual memory

If everything seems to be under control, you're just not driving fast enough
-Mario Andretti-
Please use plain text.
New Contributor
thebrave
Posts: 7
Registered: ‎02-01-2013
My Device: Developer - DevAlpha A & PlayBook
My Carrier: B&You - FR

Re: Problems installing native sdk

Glad I could help

Please use plain text.