Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
javayoung
Posts: 313
Registered: ‎05-31-2010
My Device: Alpha 10, Bold 9900, Storm 9530, Tour 9630, Curve 9320, Curve 8900
My Carrier: All
Accepted Solution

Push initiator always return -9999 due to the subscribe request from BlackBerry 10

[ Edited ]

I am trying realize push enabled application on BlackBerry 10 by using my previous Push initiator server which is working properly for my Blackberry 5-7 applications, but when it runs subscribeToPushInitiator in RegisterService, the connection of my push initiator is successful though, it returns General error( -9999) from my push initiator server for the request from BlackBerry 10 device. I am using the sample application pushCollector to test on BB10.

 

For my push initiator server, I made it from BlackBerry sample push initiator. I didn't change the low level logic.

The push sdk version is 1.0.0.5

 

Did someone meet this similar issue? Can you provide some hints for the solution?

 

Where to download the Blackberry sample push initiator server which works for BB10?

 

Thank you

 

Jarvis




p(^_^)q
Good good study, day day up
Please use plain text.
Developer
javayoung
Posts: 313
Registered: ‎05-31-2010
My Device: Alpha 10, Bold 9900, Storm 9530, Tour 9630, Curve 9320, Curve 8900
My Carrier: All

Re: Push initiator always return -9999 due to the request from BlackBerry 10

[ Edited ]

I resolved it by adding a parameter of "field1" besides with other parameters like username, model, etc.

Right now, my previous own push initiator is working properly with my BB10 push enabled app. Thank you.




p(^_^)q
Good good study, day day up
Please use plain text.