Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
Posts: 13
Registered: ‎10-05-2012
My Device: BB 10 dev Alpha
My Carrier: BSNL

Q10 performance issue.

We have  SMS message application for BB10   using PIM API  application
with same code base functions smoothly with BlackBerry Z10 whereas when we
run it on BlackBerry Q10 we get performance lag(of course there is difference in UI so we manage multiple resolution support UI as per guideline ). Some of the instances
where we have observed performance issues are like launching of
application, screen navigations, operations related to persistent storage
etc.

Do we need to take any specific care for performance optimization while
running this application on BlackBerry Q10? (Ideally same source code
should work seamlessly on both devices)

Developer
Posts: 107
Registered: ‎06-12-2012
My Device: Dev Alpha C, Playbook
My Carrier: Loop

Re: Q10 performance issue.

Is the observation on Q10 or Dev alpha C device? Also state the os versions.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Contributor
Posts: 13
Registered: ‎10-05-2012
My Device: BB 10 dev Alpha
My Carrier: BSNL

Re: Q10 performance issue.

[ Edited ]

OS version is 10.1.0.1485  and device are commercial Q10 and Dev Alpha C .. (dev alpha c is more unstable)

Developer
Posts: 1,008
Registered: ‎12-12-2010
My Device: Passport (Red Limited Edition)
My Carrier: Mobile Vikings

Re: Q10 performance issue.

Did you try profiling to determine what code is causing the lag?

-------------------------------------------
BlackBerry Certified Builder for Native Application Development -- Proud member of the Belgian BlackBerry Developer group
Samples: Park in Ghent
Feeling generous? Nominate me for BB Elite member!
Developer
Posts: 19
Registered: ‎07-02-2013
My Device: BlackBerry Q10
My Carrier: Telus

Re: Q10 performance issue.

What is the model of the Z10 (STL #)? STL-1001 runs a completely different processor than the other Z10 STL series, and Q10 series. It also has a different graphics card which might explain the difference.

However, if you are noticing anything significant it is probably a good idea to report it to BlackBerry so they can investigate the performance issue.