Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
cleft
Posts: 22
Registered: ‎12-08-2009
My Device: Not Specified
Accepted Solution

QNX IDE ERROR: The QML preview is not available

I get the following error:

The QML preview is not available.
glGetProcAddress_win32 failed: glGenFramebuffersEXT

when I try to create a new Cascades project in the QML ide. I'm running xp tablet pc version on an ibm x41 tablet pc. I installed the latest graphics drivers from Intel but no dice.

Appreciate any assistance.

Super Contributor
Meghasanghvi
Posts: 306
Registered: ‎08-10-2010
My Device: Not Specified

Re: QNX IDE ERROR: The QML preview is not available

This error come when you dont have graphics card installed.

New Contributor
jfsun
Posts: 6
Registered: ‎06-12-2012
My Device: bb10

Re: QNX IDE ERROR: The QML preview is not available

I also have the same problem of my IDE.

 

"This error come when you dont have graphics card installed."

 

that does not make sense, if I didn' t have graphic card installed, Can I use windows graphic UI??? 

 

Super Contributor
Meghasanghvi
Posts: 306
Registered: ‎08-10-2010
My Device: Not Specified

Re: QNX IDE ERROR: The QML preview is not available

[ Edited ]

You may need to install external graphics card. I previously have windows XP and in that this error not come and after upgrading my machine OS to Windows 7 this error is apper.

New Developer
cleft
Posts: 22
Registered: ‎12-08-2009
My Device: Not Specified

Re: QNX IDE ERROR: The QML preview is not available

[ Edited ]

thanks for all the responses. Getting an external grapics card sounds like the best bet. I'm curious as to why the need for such specific graphics requirements for the design preview feature of the QNX IDE.

Once I get up and running I'm sure I'll be impressed with the Cascades framework. As a .net developer I do hope also that the expected new BlackBerry Visual Studio.Net plugin adds upon the features of the old one. I enjoyed developing using the old one so I was dissapointed to learn of RIM's decision to  discontinue it. My only problem with it was that it did not allow for the design of very fancy screens for my bb application and that deployment of the app onto bb devices could only be done through a BES. If those issues are resolved in the new release I will be a very happy man.


Developer
rcmaniac25
Posts: 1,805
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.997 Dev OS, Z30 (STA100-5)-10.3.1.997 Dev OS, Passport (SQW100-1)-10.3.0.1418, PlayBook (16GB)-2.1.0.1917

Re: QNX IDE ERROR: The QML preview is not available

You need OpenGL 2.0 or higher. It may not sound like a major requirement but reality seems different (this is not the first time I have seen this issue.) It always resolves itself down to that they used intergrated graphics and that, with latest drivers, OpenGL reported itself as being less then 2.0 and it doesn't work.
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
New Contributor
jfsun
Posts: 6
Registered: ‎06-12-2012
My Device: bb10

Re: QNX IDE ERROR: The QML preview is not available

My PC video card: Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1)

my OS win7, video card worked normally after OS isntalled.

 

I got latest driver of intel chipset 15.17.18 , problem seems solved. I'll go and see what will happen next. Too much requirements for the video card driver of BB10 IDE.....

 

Thanks for you guys help

New Developer
cleft
Posts: 22
Registered: ‎12-08-2009
My Device: Not Specified

Re: QNX IDE ERROR: The QML preview is not available

jfsun, I'm glad that driver update worked for you. I was not so lucky. The OpenGL 2.0 I tried to install it but based on the errors I got during the install it seems I already have it installed somehow.So it's still not working for me.

Looking forward towards the new Visual Studio plugin....

BlackBerry Development Advisor (Retired)
mgoulet
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha

Re: QNX IDE ERROR: The QML preview is not available

Hey there,

 

You tried to install OpenGL 2.0 directly? From where did you download this?

 

Have you tried updating your video drivers to the latest from the manufacturer's website?

 

Martin

New Developer
cleft
Posts: 22
Registered: ‎12-08-2009
My Device: Not Specified

Re: QNX IDE ERROR: The QML preview is not available

I updated my video drivers to the latest from the manufacturer first. Then I tried to install openGL directly. I figure the video drivers already included openGL, hence the reason for openGL not installing.