Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
miguel_c
Posts: 12
Registered: ‎11-07-2011
My Device: BOLD, Strom, Playbook
My Carrier: Vodafone
Accepted Solution

QNX IDE Target || Selected binary and target do not match x86

[ Edited ]


I've followed the guides and installed Blackberry Playbook Native SDK and the Simulator!

 

However when I specify a target fro my project I get the erro "Selected binary and target do not match x86"

Here is a screenshot:


 

 

Anyone got the same problem?

I'm runing Windwos 7 64bit, but both the simulator and NDK installed fine on the system and AFAIK theire both x86....

thanks 

Please use plain text.
BlackBerry Development Advisor (Retired)
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: QNX IDE Target || Selected binary and target do not match x86

From your screenshot it appears that you are building for a real device b ut trying to test on a simulator. Be sure to change the "Build Configuration" to one of the Simulator* options so it can be built properly. The Device-* options can be used for testing or creating your application to be tested on the actual devices. 

 

Simulators and real devices are built with different architectures so they need different application builds.

 

Regards,

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
Contributor
miguel_c
Posts: 12
Registered: ‎11-07-2011
My Device: BOLD, Strom, Playbook
My Carrier: Vodafone

Re: QNX IDE Target || Selected binary and target do not match x86

I forgot to change that when taking the screen, but I do get the same problem.

I've also tryied to create a new device and it does not connect.

 

Stoping the vm and runing it again with vmware player did work but only for once...

I think I'll just reinstall everything, reboot and try again! 

Please use plain text.
Contributor
miguel_c
Posts: 12
Registered: ‎11-07-2011
My Device: BOLD, Strom, Playbook
My Carrier: Vodafone

Re: QNX IDE Target || Selected binary and target do not match x86

 

The connection problems seems to be gone after a restart, no need to reinstall everything!

 

I also found out waht I was doing wrong!

 

The frist time I've "Build" I just did "Build Project", so even if I then choose another build configuration it wasn't working!

 

So I right clicked the project --> Build Configurations -> Set Active -> Simulator

 

Done!

 

 

Thanks for the help 

Please use plain text.
BlackBerry Development Advisor (Retired)
cdamus
Posts: 45
Registered: ‎10-25-2010
My Device: Bold 9700
My Carrier: Rogers

Re: QNX IDE Target || Selected binary and target do not match x86

Hi, Miguel,

 

A little tip to streamline your workflow:  the C/C++ development perspective has a little "hammer" toolbar action that you can pull down (click the black triangle beside it) to set and build the active configuration in one step, for one or more projects.  The icon to its right (looks a bit like a sundial) sets the active configuration, but doesn't build.

 

HTH,

 

Christian

Please use plain text.
Contributor
miguel_c
Posts: 12
Registered: ‎11-07-2011
My Device: BOLD, Strom, Playbook
My Carrier: Vodafone

Re: QNX IDE Target || Selected binary and target do not match x86


Nice.

Many thanks for the tip!
Please use plain text.