Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
sawrubh
Posts: 34
Registered: ‎07-05-2012
My Device: Dev Alpha

Removing previous SDK

I recently installed the latest Gold SDK (10.1.0.1020) and I wish to remove the previous version (10.0.9.1673) that I had been using, however when I try to remove using the Update Native SDK dialog, it says

 

"You cannot uninstall this SDK because it's being used in this workspace. To uninstall it, please ensure that your global preference and your per-project preferences do not refer to it"

 

I have ensure that the global preference is set to use the latest SDK. How do I remove this ? How do I check the local per-project preference ? I had selected to use the global preference itself in each project.

 

Thanks in advance.

New Developer
MaxxJag
Posts: 78
Registered: ‎04-17-2011
My Device: BlackBerry Z10 LE

Re: Removing previous SDK

Since I've not run into this issue I can only guess.

 

But check your  bar-descriptors.xml to make sure none of your projects are set to older SDK, either specify 10.1 or Latest might do it.

MaxxWares.com
Current apps:
-BBOS 10-
MaxxTransit - Coming soon