Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 74
Registered: ‎01-08-2013
My Device: Playbook
My Carrier: NA

SDK update problems - segfault on debug

[ Edited ]

 

So today i tried to test in Windows rather than linux.

 

I started by updating the SDK to 10.0.10.672 from 10.0.9.***. I also had 10.1 beta installed already .

This seems to have completely messed up my installation and i got lots of corrupt shared library errors.

 

Uninstallation of all installations , delete remaining files , install momentics to new folder , import project did not help.

 

So after a lot of attempts i thought the problem was 10.1 somehow.

I can still debug and run my app without a problem but not sure if i can ignore it.

 

I went back to linux , 10.0.9 works ok. I now upgraded to 10.0.10.672 and lo

i get segfault if i debug (using simulator). segfault happens before reaching main.

Run works fine.

 

i had got this error in windows too but now i dont remember how i got rid of it ( and then got the corrupt shared libs )

Maybe it is late i made some silly mistake

 

Any one face such an issue ?

 

Can either of these 2 issues ( corrupt shared libs in windows , cannot debug in linux ) cause any problem in the generated bar file. I can test in run and my app version seems ready.

 

thanks

 

Edit:

The release export was ok and the bar file was identical to 10.0.09

For now i can debug only on 10.0.09

 

Developer
Posts: 541
Registered: ‎05-17-2009
My Device: Not Specified

Re: SDK update problems - segfault on debug

Did you try cleaning your project?

 

Scott

Developer
Posts: 74
Registered: ‎01-08-2013
My Device: Playbook
My Carrier: NA

Re: SDK update problems - segfault on debug

Yes.

For now i go back to 10.0.09 sdk on linux which works fine.

Developer
Posts: 1,670
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: SDK update problems - segfault on debug

are you working in 10.1 Beta IDE or 10.0 GOLD IDE ?

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner http://vimeo.com/ekkescorner/videos
bb10-development: http://appbus.org Twitter: @ekkescorner
Developer
Posts: 74
Registered: ‎01-08-2013
My Device: Playbook
My Carrier: NA

Re: SDK update problems - segfault on debug

[ Edited ]

10.0 Gold IDE (i think it has 1673 sdk by default)

On windows i had used 10.1 IDE alongside 10.0 to check Q10 but not on linux.

 

10.0.10 sdk debug doesnt work for me but i guess its not so important. I will use 10.0.9 and then switch when 10.1 goes gold and gets pushed to Z10.

 

 

 

Developer
Posts: 1,670
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: SDK update problems - segfault on debug

I had a problem with one project from 10.0 after working with 10.1 on this and later going back to 10.0.

had to create new project in 10.0 and copy src and assets into

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner http://vimeo.com/ekkescorner/videos
bb10-development: http://appbus.org Twitter: @ekkescorner
Developer
Posts: 74
Registered: ‎01-08-2013
My Device: Playbook
My Carrier: NA

Re: SDK update problems - segfault on debug

on linux i only did sdk update with same ide. Didnt install 10.1. Get seg fault before main if i debug , maybe from gdb not sure. but anyway i think ill just go from 10.0.09 to 10.1 whenever its released.