Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
mmarion
Posts: 60
Registered: ‎05-03-2013
My Device: Z10

Slow debug startup

Anyone else have excruciatingly slow debug startup when debugging on the device via USB?

 

Every app I've made so far has taken forever for debug to actually fully launch the app on the phone.  I also get a tonne of warnings along the lines of:

 

warning: Could not load shared library symbols for /base/usr/lib/graphics/msm8960/libOSUser.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for /base/usr/lib/graphics/msm8960/libpanel.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for /base/usr/lib/graphics/msm8960/libGSLUser.so.
Do you need "set solib-search-path" or "set sysroot"?
warning: Could not load shared library symbols for /base/usr/lib/graphics/msm8960/egl14.so.
Do you need "set solib-search-path" or "set sysroot"?

I just triggered a debug session with fully built code and it took 1.5 minutes to launch the app.  This is with almost no functionality.

 

Anyone also go through this and figure out how to speed it up?  A minute plus is a lifetime when sitting there waiting for it and while I could do other things, how much can be accomplished in a minute.  If it's just to verify something small is working correctly then it can really hurt.

 

Thanks,


Matt M

Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Slow debug startup

What version of the NDK are you on?

There was a change, I forget which version, where speed of startup was traded for stability but 1.5 minutes seems excessive.

 

Fairly new PC?

 

Are you counting app transfer time in that 1.5?


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Slow debug startup

Oh, and you can ignore those warnings they are nothing to do with your app or the slow down.


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Developer
simon_hain
Posts: 16,282
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport

Re: Slow debug startup

debugging got a lot quicker when i upgraded to 10.2/10.2.1
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Developer
mmarion
Posts: 60
Registered: ‎05-03-2013
My Device: Z10

Re: Slow debug startup

I'm on 10.2, newest. It's done this since I moved from 10.9. 8 gigs of ram in my laptop and it's pretty quick. I've also had this happen on three separate machines now with completely separate and new install each time. This time it's a vanilla install of 10.2 and on top of that full out new projects. I keep everything in SVN including project files but when I move versions I create a new project and stick the source in then manually update the .pro and other files.

 

It's been frustrating me since my first app last year. I've seen two other posts saying the same thing but no solution so I'm trying here.

 

App transfer should be instant. Right now it's a navpane with on page in it that has 5 things on it. No icon, nothing.

Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Slow debug startup

It's about 18 seconds for me, so given what you've said the only common factor is your device and/or possibly your usb cable.


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Developer
mmarion
Posts: 60
Registered: ‎05-03-2013
My Device: Z10

Re: Slow debug startup

I have 3 z10's and it's happened on all of them and I use different USB wires depending on where I am.  Sometimes my laptop is plugged into a docking station and the USB goes through that, sometimes it's directly into the laptop and in that case I change wires constantly (like many people I have a tonne of USB wires lying around).

 

So 3 phones, 3 different laptops now, multiple different USB wires in different configurations and mutltiple versions of the SDK, freshly installed.  New projects created with with project wizard of the new SDK and almost no code takes as long as my other full out app.

 

I guess the search continues.  I need to figure out how to trace it but I really don't have time for that.  What I do now is just don't test until I've layed down a tonne of code but I like to test everything in case there's behavior I didn't plan for.

 

Are there any logs anywhere I can look at to try to get an idea of where the delay is (anyone know)?

Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Slow debug startup

Not that I know of, try submitting a report via the Momentics bug report system it will upload a log file with it and maybe BlackBerry can see something within it and suggest something.

 


If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.
Developer
mmarion
Posts: 60
Registered: ‎05-03-2013
My Device: Z10

Re: Slow debug startup

I should also mention that the app is launched on the Z10 quite quickly but just sits there with the app open but only showing a black background with Blackberry written in the middle.  It sits like this for almost the entire time before my widgets show up.

 

I deleted the log file to generate a new fresh one for just this debugging run so I'll see if there's anything in it that can help me out.

Developer
BBSJdev
Posts: 6,116
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30

Re: Slow debug startup

Silly question but you do know there is a breakpoint automatically set on main right and you would need to click on the resume button to get past it?

If you've been helped click on Like Button, if you've been saved buy the app. :smileyhappy:

Developer of stokLocker, Sympatico and Super Sentences.