Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
Posts: 7
Registered: ‎12-08-2011
My Device: Playbook

Slow to download application to simulator

I'm currently developing a native application using OSX as the host machine. When I try to run a sample application, it takes several minutes to get the application to the simulaor. During this time, the progress dialog in eclipse shows the message "Downloading and starting the application". 

 

Is there any way to speed up the downloading of applications to the simulator? It's a huge time sink just waiting for this everytime I need to run the application after making a small change to code.

 

Any ideas?

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Slow to download application to simulator

Hi,

 

Could you provide some more information behind this scenario:

- Are you connecting to the device over WiFi or USB?

  - If USB, is file sharing currently enabled?

- Does this issue reproduce with every application tested? Does it occur using the sample HelloWorld application?

- Could you let us know the average load time seen with an application?

- What is the OS of the PlayBook used for testing? Did you notice this with previous OS versions?

 

Regards, 

Garett
@garettBeuk
--
Goodbye everybody!
BlackBerry Development Advisor
Posts: 417
Registered: ‎10-27-2010
My Device: PlayBook

Re: Slow to download application to simulator

It can happened if computer do not have internet connection. For some reason simulator connection is very slow in this case.

New Member
Posts: 1
Registered: ‎06-25-2012
My Device: Playbook simulator

Re: Slow to download application to simulator

I also have this problem and my playbook simulator has internet connection...