Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
dmitrykos
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None
Accepted Solution

Strange behavior of audio sub-system after updating Dev Alpha 10 to 10.0.9.388

[ Edited ]

Hi Everybody!

 

Has anyone noticed strange behavior of audio sub-system behavior of 10.0.9.388 firmware. Recently after updating Dev Alpha 10 to 10.0.9.388 firmware the audio sub-system misbehavies in the following ways:

 

1) If external speakers/headset connected to the line-out jack audio looks like being preprocessed by low-pass filter and surround effect. The device reported by AudioManager is /dev/snd/pcmPrefferedp. Could it be a bug in formware and audio re-routing from internal speaker to line-out jack did not exclude this specific preprocessing?

 

2) On earlier firmwares if audio is coming out from the internal speaker and then headset is connected to line-out jack rerouting was happening seemlesly and it kept playing in headset without additional actions in the application. Now audio device is not consuming audio samples and thus gets stuck until it is closed and re-opened.

 

On earlier firmwares there wern't any problems of such sort. Could it be some unlucky firmware flashing attempt (if it is ever possible), or bug of 10.0.9.388.

 

It will be great to hear comments & thoughts regarding these issues.

 

Best regards,

Dmitry.

Please use plain text.
Developer
Innovatology
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: Strange behavior of audio sub-system after updating Dev Alpha 10 to 10.0.9.388

I suggest creating two Issue Tracker entries: https://www.blackberry.com/jira

 

 

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
Please use plain text.
Contributor
dmitrykos
Posts: 17
Registered: ‎08-01-2012
My Device: Blackberry 10 Alpha Device
My Carrier: None

Re: Strange behavior of audio sub-system after updating Dev Alpha 10 to 10.0.9.388

Thank you for the proposal. Opened the following tickets:

 

Audio modified:

https://www.blackberry.com/jira/browse/BBTEN-335

 

Audio device stops on connection change:

https://www.blackberry.com/jira/browse/BBTEN-336

 

Please use plain text.