Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange
Accepted Solution

Struggling after with 10.0.6.545 Update

After install new update on BB 10 alpha device i am unable to run any application. Getting error in every application for example

ldd:FATAL: Could not load library libbb.so.0

In 2nd apps i am getting this

 

Error loading font /usr/fonts/font_repository/adobe/MyriadPro-Bold.otf

Unable to initialize app logic

 

Any suggestion ?

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: Struggling after with 10.0.6.545 Update

same error i am getting

http://bb10dev.net/document.pl?mode=Display&DocumentID=943

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: Struggling after with 10.0.6.545 Update

Went through this thread but no help.

 

http://supportforums.blackberry.com/t5/Cascades-Development/My-beta1-app-won-t-open-when-compiled-an...

 

 

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.
Developer
discnick
Posts: 17
Registered: ‎05-30-2012
My Device: Blackberry 10 Alpha Device
My Carrier: Cosmote

Re: Struggling after with 10.0.6.545 Update

Same problem here, a segmentation fault when executing the

 

createRootUIObject(QDeclarative *context)

 

function in the QmlDocument class.

 

Has anyone tried reinstalling the Cascades SDK yet?

Please use plain text.
Developer
BryceMcMurter
Posts: 32
Registered: ‎05-21-2012
My Device: Bold 9900 & Playbook
My Carrier: Telus

Re: Struggling after with 10.0.6.545 Update

I think its is a incompatibility with the new beta 2 sdk. If you made a program while you had the original build on the dev alpha and the original SDK and have now updated your Dev Alpha you might need to update to the new beta 2 sdk, create a new project and copy/paste your code in.

 

Im having the same problem right now. Im going to try to update the SDK to beta 2 and I will see what happens

Please use plain text.
Developer
discnick
Posts: 17
Registered: ‎05-30-2012
My Device: Blackberry 10 Alpha Device
My Carrier: Cosmote

Re: Struggling after with 10.0.6.545 Update

I have reinstalled the SDK but the same problems occured.

 

Then I looked at the examples which were running fine and then uppon my code and made some changes. It seems that creating the root node right after the QmlDocument object creation was critical.

 

QmlDocument *doc = QmlDocument::create("main.qml");

AbstractPane *root = qml->createRootNode<AbstractPane >();

 

Now the application runs smoothly..

Any hints on this anyone?

Please use plain text.
BlackBerry Development Advisor (Retired)
mgoulet
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: Struggling after with 10.0.6.545 Update

Hi there,

 

As an intermediate solution, can you confirm that you have tried what is suggested by to create a new project and drop your files in?

 

Martin

Please use plain text.
Developer
BryceMcMurter
Posts: 32
Registered: ‎05-21-2012
My Device: Bold 9900 & Playbook
My Carrier: Telus

Re: Struggling after with 10.0.6.545 Update

Hey Martin

I can confirm that after installing the beta2 SDK and copy/pasting my code into a new project everything was back up and running for me.

Thanks

Bryce
Please use plain text.
BlackBerry Development Advisor (Retired)
mgoulet
Posts: 329
Registered: ‎05-07-2012
My Device: BB Alpha
My Carrier: N/A

Re: Struggling after with 10.0.6.545 Update

Thanks for the confirmation BryceMcMurter. , have you tried this?

 

Martin

Please use plain text.
Developer
kamal_nigam
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: Struggling after with 10.0.6.545 Update

not yet.will update this thread once i will done.

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Please use plain text.