Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
helex
Posts: 293
Registered: ‎02-14-2012
My Device: Nokia N950 / BB Playbook

Re: SystemDialog - onFinished: not working since Gold Beta

Confirmed, I removed the SystemToast from my code and SystemDialog works now just fine!

Developer
ekke
Posts: 1,566
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: SystemDialog - onFinished: not working since Gold Beta


helex wrote:

Confirmed, I removed the SystemToast from my code and SystemDialog works now just fine!


you should open an issue

 

(there are also problems with SystemDialog, SystemProgressDialog from C++)

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner http://vimeo.com/ekkescorner/videos
bb10-development: http://appbus.org Twitter: @ekkescorner
Contributor
A7omic
Posts: 48
Registered: ‎11-03-2011
My Device: Playbook

Re: SystemDialog - onFinished: not working since Gold Beta

Have any of you had any success with this yet?  I have both SystemDialogs and taosts, onFinished is working perfectly fine in my SystemDialogs but it is not working at all in my toasts.

Developer
helex
Posts: 293
Registered: ‎02-14-2012
My Device: Nokia N950 / BB Playbook

Re: SystemDialog - onFinished: not working since Gold Beta

No success over here. But it is the other way around over here. SystemToast working fine, but the SystemDialog doesn't. Bug reported, but it is marked as private as usual. So doesn't make sense to post a link to the report over here. But I let a information about this discussion at the Issue Report.

 

I have already tried to put the SystemDialog inside a ComponentDefinition {} and load it just before I use it. But without success. I haven't tried to put the SystemToast instead of the SystemDialog inside a ComponentDefinition {}, perhaps this could have solved the issue, I don't know. :smileysad:

 

The solution for me was to change my Application and simply don't use the SystemToast. :smileyhappy:

Developer
ekke
Posts: 1,566
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: SystemDialog - onFinished: not working since Gold Beta

also having huge problems with SystemDialog, SystemProgressDialog, ...

 

got the information that it should work much better with next OS

hope next version will be available soon

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner http://vimeo.com/ekkescorner/videos
bb10-development: http://appbus.org Twitter: @ekkescorner
Regular Contributor
_NishantShah
Posts: 76
Registered: ‎07-31-2012
My Device: Blackberry

Re: SystemDialog - onFinished: not working since Gold Beta

Hi A7omic,

Which device are you using? I have both Dev Alpha A and Dev Alpha B. It reproduces on Dev Alpha A but works fine on Dev Alpha B. I know this sounds really silly. There's no relevance with hardware. Even I was shocked when I observed this.

Developer
helex
Posts: 293
Registered: ‎02-14-2012
My Device: Nokia N950 / BB Playbook

Re: SystemDialog - onFinished: not working since Gold Beta


_NishantShah wrote:

Which device are you using? I have both Dev Alpha A and Dev Alpha B. It reproduces on Dev Alpha A but works fine on Dev Alpha B. I know this sounds really silly. There's no relevance with hardware. Even I was shocked when I observed this.


WOW! I hope this isn't true. I have a Dev Alpha A over here. I thought the Hardware is Binary compatible.

Developer
ekke
Posts: 1,566
Registered: ‎04-08-2010
My Device: Z10 (red Limited Edition), Q10, Z30
My Carrier: Telekom.de, O2, Vodafone

Re: SystemDialog - onFinished: not working since Gold Beta

for me it fails on Dev Alpha A and B

-------------------------------------------------------------------------------
ekke (independent software architect, rosenheim, germany)

BlackBerry Elite Developer
BlackBerry Platinum Enterprise Partner
International Development Mobile Apps BlackBerry 10 Cascades
Cascades - Workshops / Trainings / Bootcamps

blog: http://ekkes-corner.org videos: http://www.youtube.com/user/ekkescorner http://vimeo.com/ekkescorner/videos
bb10-development: http://appbus.org Twitter: @ekkescorner
Contributor
A7omic
Posts: 48
Registered: ‎11-03-2011
My Device: Playbook

Re: SystemDialog - onFinished: not working since Gold Beta

I am using the Dev Alpha A.

Regular Contributor
_NishantShah
Posts: 76
Registered: ‎07-31-2012
My Device: Blackberry

Re: SystemDialog - onFinished: not working since Gold Beta

[ Edited ]

Yeah helex it is. I am stil not sure how is this possible. But for me same code works on Dev Alpha B but not on Dev Alpha A.