Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Highlighted
Developer
Posts: 82
Registered: ‎11-04-2011
My Device: PlayBook, DAC, SQN100-3, STL100-1, STL100-2
My Carrier: MTS RUS

SystemDialog, "Context: Failed to find target node with id 0"

I have a page with attached SystemDialog object

 

 attachedObjects: [
        SystemDialog {
            id: attemptToDeleteProfileHistoryDialog;
            body: "Do you really want to delete profile?";
            cancelButton.label: "No";
            confirmButton.label: "Yes";
            title: "Delete profile";
            
            onFinished: {
                if (SystemUiResult.ConfirmButtonSelection == attemptToDeleteProfileHistoryDialog.result) {
                    // processing
                }
            }  
        }
]

 

and ActionItem, which shows this dialog.

 

    actions: [
  ActionItem {
            title: "Delete profile history";
            imageSource: "asset:///images/dark/icons/cancel.png";
                    
            onTriggered: {
                attemptToDeleteProfileHistoryDialog.show();
            }
        }
    ]

 

When I invoke action and choose 'Yes' option, I often get following "Context: Failed to find target node with id  0" debug message in the console output and onFinished handler is not triggering at all.

 

Is it correct usage of the SystemDialog or I should to avoid it at this moment?

 

Developer
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: SystemDialog, "Context: Failed to find target node with id 0"

I also see the same behavior with actionitem sometimes but I dont know if the behavior and that console message are related.
Like all of my posts
Developer
Posts: 82
Registered: ‎11-04-2011
My Device: PlayBook, DAC, SQN100-3, STL100-1, STL100-2
My Carrier: MTS RUS

Re: SystemDialog, "Context: Failed to find target node with id 0"

[ Edited ]

As I see this console message is happened when I open a page ActionBar with action items, so it's unrelated.

I also open a ticket BBTEN-584.