Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Chambras
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook

Ubuntu installer error

[ Edited ]

I am trying to install the native SDK on my Ubuntu 12.10 32 bit but I am getting this error everytime I try.

 

[marcelo@Venus Downloads]$ ./installer-bbndk-bb10_0_09-linux-386-201209241008-201209241243.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)

Stack Trace:
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
    at java.util.Properties.loadConvert(Unknown Source)
    at java.util.Properties.load0(Unknown Source)
    at java.util.Properties.load(Unknown Source)
    at com.zerog.common.java.util.PropertiesUtil.loadProperties(DashoA10*..)
    at com.zerog.lax.LAX.<init>(DashoA10*..)
    at com.zerog.lax.LAX.main(DashoA10*..)

 

I do have Java  SE 6 installed. Any ideas on waht could I be doing wrong?

I even tried installing the ia-32libs libraries and nothing:

sudo apt-get install ia32-libs-multiarch

 

Thanks.

Developer
Chambras
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook

Re: Ubuntu installer error

I tried the latest update which is beta and it is still failing with pretty mush the same error:

[marcelo@Venus Downloads]$ ./installer-bbndk-bb10_0_09-linux-1101-201211092310-201211092228.bin 
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

An internal LaunchAnywhere application error has occured and this application cannot proceed. (LAX)

Stack Trace:
java.lang.IllegalArgumentException: Malformed \uxxxx encoding.
	at java.util.Properties.loadConvert(Unknown Source)
	at java.util.Properties.load0(Unknown Source)
	at java.util.Properties.load(Unknown Source)
	at com.zerog.common.java.util.PropertiesUtil.loadProperties(Unknown Source)
	at com.zerog.lax.LAX.<init>(Unknown Source)
	at com.zerog.lax.LAX.main(Unknown Source)

 

New Developer
aceperry
Posts: 7
Registered: ‎12-19-2010
My Device: Style

Re: Ubuntu installer error

I'm also getting an istall error with the latest linux native SDK installer.  I'm running Ubuntu 12.10 64 bit.  Here's the output:

 

 

perry@aguila:~/Downloads/Blackberry$ ./installer-bbndk-bb10_0_09-linux-1101-201211092310-201211092228.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

./installer-bbndk-bb10_0_09-linux-1101-201211092310-201211092228.bin: 3320: exec: /tmp/install.dir.5466/Linux/resource/jre/bin/java: not found

 

Looking in the directory, I find '/tmp/install.dir.5466/Linux/resource/jre/bin/java' is there and is executable.  It's possibly an error in the script, not referencing a file somewhere.

Developer
Chambras
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook

Re: Ubuntu installer error

Looking inside that temp table you said I found a file named temp.lax I it gives a little more information about the error. This is the content of my file

lax.user.dir=/tmp/install.dir.2934
lax.resource.dir=Linux
lax.class.path=/tmp/install.dir.2934/InstallerData:/tmp/install.dir.2934/InstallerData/installer.zip
lax.main.class=com.zerog.ia.installer.Main
lax.main.method=main
lax.nl.message.vm.not.loaded=The installer either could not find a Java VM, or the Java VM on this system is too old. The installer requires Java 1.1.5 or later. It can be downloaded from http://java.sun.com/products/jdk/1.1/jre/
lax.nl.java.launcher.main.class=com.zerog.lax.LAX
lax.nl.java.launcher.main.method=main
lax.command.line.args=$CMD_LINE_ARGUMENTS$
lax.nl.current.vm=/tmp/install.dir.2934/Linux/resource/jre/bin/java
lax.nl.java.compiler=off
lax.nl.java.option.verify.mode=none
lax.nl.java.option.check.source=off
lax.stderr.redirect=/tmp/bbndk-stderr.txt
lax.stdout.redirect=/tmp/bbndk-stdout.txt
lax.nl.java.option.java.heap.size.initial=536870912
lax.nl.java.option.java.heap.size.max=1073741824
lax.nl.java.option.additional=-d32
lax.installer.unix.internal.property.0=bin/java
lax.installer.unix.ui.default=GUI
INCLUDE_DEBUG=true

 If you see, it says "lax.nl.message.vm.not.loaded=The installer either could not find a Java VM, or the Java VM on this system is too old. The installer requires Java 1.1.5 or later. It can be downloaded from http://java.sun.com/products/jdk/1.1/jre/" the problem is that I do have java sun 1.6 installed. If i go to the comman line and execute java -version I get this:

java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03)
Java HotSpot(TM) Server VM (build 20.8-b03, mixed mode)

 for some reason the installer is not finding it.

 

I keep thinking that we should get just a tar file or something simpler.

Developer
Chambras
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook

Re: Ubuntu installer error

The installer is still failing even with the gold release. is anyone else testing this?

 

I tried following the steps on this blog post:

http://goo.gl/3dEyx 

and nothing still the same error!

BlackBerry Development Advisor
ayun
Posts: 3
Registered: ‎12-05-2011
My Device: PlayBook

Re: Ubuntu installer error

On Linux and Mac computers, the installer might crash when launching with an error similar to the following: "An internal LaunchAnywhere application error has occurred and this application cannot proceed." Unset the PS1 variable and restart the installation program to continue.

 

As for the other issue with tmp, you will need a local user account to proceed installation.

Developer
Chambras
Posts: 34
Registered: ‎02-04-2012
My Device: BlackBerry PlayBook

Re: Ubuntu installer error

what do you mean a local user account? I am running all this using a local user in my computer and if you see the log it seems it is not finding java, but I do have java 6 installed.

 

Is there a better way to debug or anything else I can try to make it work?

 

Thanks for the help.

New Member
timsavage
Posts: 1
Registered: ‎04-15-2013
My Device: Z10

Re: Ubuntu installer error

Had the same fun and games, but basically do this.

 

unset PS1; ./installer-bbndk-bb10_1_x-linux-1020-201303191709-201303191501.bin

 

That should do the trick. Note that your terminal will no longer have a prompt post install, but you can just close the terminal when done.

 

If you are on a 64bit machine you will also need those 32bit libs from the other post you linked to.