Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Posts: 38
Registered: ‎12-06-2011
My Device: Playbook 64GB, Curve 9360, BB Z10 LE
My Carrier: Koodo
Accepted Solution

Unable to deploy app

Hi all,

 

I am having the following issue :

 

I have an app but it has a bug in it, which I'm trying to chase down. The bug causes the app to not close properly (so the icon is greyed out). Once the icon is greyed out I cannot deploy the app again without restarting. Even uninstalling the app doesn't solve this. The message is :

 

Deployment Failed: Info: Sending request: Launch
Info: Action: Launch
Info: Debug native: on
Info: Launching com.example.FixIt.testDev_ample_FixItdd6a40cf...
result::Invalid
Info: done

 

This is a huge frustration and costing too much time. Any suggestions/ideas (I know - fixing that bug would be ideal, but this issue has hit me even before the bug was introduced).

 

Thanks,

 

Gerry

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Unable to deploy app

It's possible this post, or others in that thread, will help you avoid the need to reboot: http://supportforums.blackberry.com/t5/Cascades-Development/Beta-4-WebView-app-freeze-post-exit/m-p/...

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
Posts: 38
Registered: ‎12-06-2011
My Device: Playbook 64GB, Curve 9360, BB Z10 LE
My Carrier: Koodo

Re: Unable to deploy app

Thanks, exactly what I was looking for!