Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 10
Registered: ‎03-11-2014
My Device: Z10
My Carrier: BITE Latvia
Accepted Solution

Unexpected notification red star (sparkle) icon (BB10 native)

[ Edited ]

I have a headless app that is using NotificationMode, NotificationGlobalSettings and NotificationPolicy classes.

Not so long ago I was using Notification class to post hub notifications. It was a temporary solution, for logging/debugging only, and it was completely deleted, when there was no need in it anymore.

The issue is, that when i reboot my device (Z10, 10.2.1), the red notification sparke appeares on my app icon, but there is no sign of any related messages in the hub. As the UI part is not even launched, I assume something is wrong with headless part. This issue occures only on reboot. When I install bar package, or run the app in debug mode, everything is fine.

I can't even imagine, what might cause this. Notification icon is just there for no particular reason.

Maybe there is a known cause/bug? Some cached settings, or any in-app errors, that might post this red sparkle?

 

Thanks in advance!

Highlighted
New Developer
Posts: 10
Registered: ‎03-11-2014
My Device: Z10
My Carrier: BITE Latvia

Re: Unexpected notification red star (sparkle) icon (BB10 native)

Solved it myself.
Posted hub notification, deleted it manually, then rebooted the device, and called deleteAllFromHub and clearEffectsForAll. Removed unneeded imported classes and functions, again rebooted the device, and red sparkle was gone.