Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: Upgrading to BETA 4

Oops, I didn't realize Q-T had posted to an existing thread and thought his was the first post. Sorry.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
jaiaca
Posts: 96
Registered: ‎10-06-2012
My Device: Z10

Re: Upgrading to BETA 4

I'm running on a Mac and I've installed Beta4 along side with Beta3 and I haven't had any issues with Cascades so far (i.e. building and deploying existing beta3 apps work fine)
Jason I. Carter
Follow me @jasonicarter
Built For BlackBerry - WordsPlus & WordsPlus: Free Edition | word search has never had it so good
www.twocasualcoders.com | never casual on quality
Developer
djogon
Posts: 93
Registered: ‎10-29-2012
My Device: Z10

Re: Upgrading to BETA 4

So the exact procedure for Mac OSX 10 is as follows:

 

1) Simply install the BETA 4 without uninstalling anything. This will install the new SDK and tools alongside the old ones.

2) Start Momentics and open its preferences. Click on the QNX node and make sure you select the latest SDK. This option is available from the drop-down menu on the toolbar as well, but if you go to preferences you can actually see the paths where SDKs are stored so that you can at some point remove the old ones if you wish.

 

Screenshot attached.

 

I assume that the procedure is similar for Windows machines.

 

Developer
tommy20
Posts: 262
Registered: ‎05-18-2011
My Device: Curve 9300, BB10 Dev Alpha C, Z10

Re: Upgrading to BETA 4

@RIM representatives:

 

Please provide links or documentations for "how to upgrade to BETA 4", please!!! It is fine even if you can just say "remove the old one and insall the new one". But we you your confirmation.

 

Thanks.

--tom
Developer
georg22
Posts: 247
Registered: ‎11-22-2011
My Device: Blackberry Playbook

Re: Upgrading to BETA 4

I did'nt remove Beta3 and installed Beta 4 to another directory. Loading the old Workspace created with Beta3 worked so far. I only needed to change the SDK -version in the IDE to 1101.

I think its important to start the installer as Administrator.

OS: Windows Vista (oh yes, i know...) 64.