Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
Bullety
Posts: 138
Registered: ‎08-02-2009
My Device: Z10
My Carrier: T-Mobile

Use/compile gcrypt library on/for BlackBerry 10

Hi,

 

I am developing a cascades application that needs to use libgcrypt and it's dependency libgpg-error but I am not able to compile it the correct way so that I can link to the compiled library from my primary project.

 

I tried setting up both libgcrypt and libgpg-error as separate static library projects in the QNX Momentics IDE but I am not sure how to configure the projects to be compiled the correct way for simulator and device build configurations.

 

Did anyone ever get this libs compiled?

Please use plain text.
Developer
Bullety
Posts: 138
Registered: ‎08-02-2009
My Device: Z10
My Carrier: T-Mobile

Re: Use/compile gcrypt library on/for BlackBerry 10

[ Edited ]

I think I got a bit further but still got problems getting this to run.

 

I managed it to get the librarys build on their own but as soon as I link them statically from my primary project, I get strange build errors in my primary project ("...has been declared before...").

I think there is a problem because these librarys are compiled as C code but my primary library is compiled as C++ code.

Please use plain text.