Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 10
Registered: ‎01-14-2013
My Device: Blackberry 10 Simulator
My Carrier: EE
Accepted Solution

Weird issue just started - Changes in my .cpp file is not being used?

I've got a strange problem with my application. I've got a working application that I've built and submitted for review. I've just come to do some edits and add a feature but I'm finding that when i make changes to my .cpp file (as simple as changing debug messages) the application that is deployed to the simulator is not mirroring them. It's just stuck. It works fine even after I comment out lines that should break/alter the application.

 

Anyone know why/how this could be happening? It was working fine a couple days ago just before exporting a release build for submission.

Developer
Posts: 526
Registered: ‎05-17-2009
My Device: 9900
My Carrier: ATT

Re: Weird issue just started - Changes in my .cpp file is not being used?

Delete the app from the simulator? Clean and rebuild the project from scratch?
Like all of my posts
New Developer
Posts: 10
Registered: ‎01-14-2013
My Device: Blackberry 10 Simulator
My Carrier: EE

Re: Weird issue just started - Changes in my .cpp file is not being used?

That's what I did in the end. I just made a new project with the same name (renamed prior project folder) and copied over files etc.

All sorted, I must've broken something in one of the config files or something :s