Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
madhanbalus
Posts: 18
Registered: ‎02-10-2012
My Device: playbook

Working with GIF images in Qt

Hello all,

 

    I need to load an animated gif image in playbook. In symbian we used to do using QMovie("file.gif") which actually displays the animated image.. but here in playbook it doesn't seem to be working. I have included -e $$[QT_INSTALL_PLUGINS]/imageformats/libqgif.so lib/imageformats/libqgif.so in the .pro file. Any workarounds?

 

 

Thanks,

Madhan

 

 

Developer
jheron
Posts: 188
Registered: ‎01-27-2012
My Device: playbook

Re: Working with GIF images in Qt

I had to add the env variable in the descriptor xml to get my gif images to work, I was not using gif animations though.

Here is what I used to get them working:

pro:
-e $$[QT_INSTALL_PLUGINS]/imageformats/libqgif.so lib/plugins/imageformats/libqgif.so
blackberry-tablet.xml:
<env var="QT_PLUGIN_PATH" value="app/native/lib/plugins"/>

 Good luck!

Jon

Regular Contributor
Megha_9_dec
Posts: 56
Registered: ‎08-21-2012
My Device: BB10

Re: Working with GIF images in Qt

[ Edited ]

Hi jheron,


I want to load a GIF file on application launch of my BB10 dev alpha device. Can you please guide me with steps?

 

I tried adding env var inside descriptor xml file & also added the line provided by you in .pro file. I'm getting a parsing error inside .pro file

_______________________________________________________________________________________
make Device-Release
D:/bbndk3/host_10_0_9_52/win32/x86/usr/bin/qmake -spec unsupported/blackberry-armv7le-qcc -o arm/Makefile TrackMyCar.pro CONFIG+=device

: Parse Error ('-e $$[QT_INSTALL_PLUGINS]/imageformats/libqgif.so lib/plugins/imageformats/libqgif.so')

---------------------------------------------------------------------------------------------------------------------------------------------------------

 

Am I missing something to add/install ?

Developer
jheron
Posts: 188
Registered: ‎01-27-2012
My Device: playbook

Re: Working with GIF images in Qt

Are you using the pro file or the descriptor to deploy the Qt libs?

As long as the gif plugin is where it needs to be on the device, it should work regardless of how you deploy it.

app/native/plugins/imageformats/libqgif.so

is where it should be.

Wait a minute, does the bb10 not have the Qt libs on board already?

If the imageformats dir is not on the device maybe you just need to copy the dir over onto the device... If you dont have a set of them compiled I can put them up...

Cheers,

Jon