Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Contributor
qqworini
Posts: 5
Registered: ‎01-01-2013
My Carrier: cmcc

blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

Hi Geeks,

 

There's a problem seems the blackberry 10 simulator only works in safe mode in my machine , can somebody help?

 

subject: bb 10 simulator

result: only safe mode works

expect: nomal mode works with all controller featrues

 

OS: Kubuntu 12.04 32 bit

kernel: Linux 3.2

machine: ThinkPad X230

CPU: Intel IVB I5 3210M with VMT enabled

Graphic: Intel HD 4000 with opengl ES 3.0 support

memory: 6GB

 

Thank you for your replies

Please use plain text.
Regular Contributor
MindOperations
Posts: 64
Registered: ‎03-04-2010
My Carrier: VZN

Re: blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

[ Edited ]

There has been alot of issues around vmware running the simulator on ubuntu.  One thing was the kernals it was using and another was making sure build essentials was loaded. 

 

For others: If your system is 64bit you need to load the 32bit library (ai32-libs). Your kernal may be different, possibly something like linux-headers-3.2.0-23-generic.

 

sudo apt-get install linux-headers-3.5.0-21-generic build-essential ai32-libs

 

I was also had to get around my issues by only installing the simulator without root access above the home directory. and disabling updates and checks on the vmware install.  I also noticed if I dont power off vmware before closing it that I need to uninstall it and reinstall it.  I am running 12.10 but its not that big of a difference. Hope that helps.

Brandon Clark
The Mind Company | www.themindspot.com

Please use plain text.
New Contributor
qqworini
Posts: 5
Registered: ‎01-01-2013
My Carrier: cmcc

Re: blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

Thanks 4 ur reply

 

After I installed kernel 3.5 , it is still fail to boot in normal mode (safe mode works), and I tried uninstall and reinstall the simulator, still not work.

 

PS: I'm a Qt developer , all compile or build packages are installed if needed

 

:Yes:

Please use plain text.
Regular Contributor
MindOperations
Posts: 64
Registered: ‎03-04-2010
My Carrier: VZN

Re: blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

[ Edited ]

You need to install the kernal related to your version.  Version 3.5 is mine because I am using 12.10.  If you are unaware of your kernal try using the TAB key to finish it for you.

Brandon Clark
The Mind Company | www.themindspot.com

Please use plain text.
Regular Contributor
robinhuang
Posts: 52
Registered: ‎02-08-2013
My Carrier: Rogers

Re: blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

 

I have the same issue at both 32 bit and 64 bit Ubuntu 12.04. It stucks at START SERVICE: screen.

Please use plain text.
New Contributor
qqworini
Posts: 5
Registered: ‎01-01-2013
My Carrier: cmcc

Re: blackberry 10 simulator issue on Ubuntu 12.04 with Intel HD4000

pls choose the second mode: safe mode, to disable the graphic card accelerate (maybe driver issue)

Please use plain text.