Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1154, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: camera and screenshot not work

Ok, finally got the time to contact support. Here is everything I did.

 

I will preface that I am in the US.


I went on the BlackBerry site and choose Support->Tablets

 

In the upper-right is "Warranty & licenses", hover over that and choose BlackBerry PlayBook Warranty.

 

Find your country and language and choose "Get Support"

 

Enter your PlayBook serial number in the direct support box at the bottom. This pre-registers you when you call it goes a little quicker. I was past the 90 day period for direct support so I called support number (9:45PM)

 

Followed the prompts to tablet support.

 

Needed my PlayBook serial number in order to call.

 

Since I couldn't pre-register, I got a person and they wanted my country, state, name, email, and phone number.

 

I explained my issue, stated I asked on the support forums and they directed me to support. The person entered in some information on there end and asked me to put my serial number into the direct support box. This time I got a request for my email. Entered that. It registered and comically told me that my complimentary support period would end in June and that I have "-223 days remaining".

 

The support person wanted to make sure that it wasn't a botched OS update. So he asked if I had data on it that I wanted to keep (otherwise, I assume, he would ask me to back it up). I keep backups so I said no. He asked me to turn it off and plug it into my computer and run the Desktop software. Using that forced a OS reinstall (if you haven't done this, plug in a turned off BlackBerry/PlayBook into your computer. Desktop software will tell you it couldn't connect and ask if you want to update it. Click update, uncheck email on new versions, and click install).

 

He told me that he would do a "callback", I asked for 10:30. I never received a callback (maybe I mistook it as I am supposed to callback). Regardless, went to bed.

 

I received emails with incident number.

 

Today at about 1:30PM, called again. Entered in my incident number at prompt. Got a different person. Explained to that person my issue and all the symptoms (rear facing camera works, front facing camera shows nothing. UI elements show. Asked on forums, was told that the camera service also does screen shots. I tried screen shots and they didn't work. I was advised to call support.). He did some checks and said that they would do a same-unit replacement (so a basic repair).

 

He hung up and a RMA agent came on.

 

RMA agent took street address, phone number, and email.

 

I got an email with the RMA terms and conditions. I replied "I accept" as it requested.

 

I was told I would get a pre-paid box (1-2 business days). Inside it were papers that needed to be filled out. I would also get a RMA number (email) and PDF (email) that I would have to fill out. I would then put all the signed papers. The signed PDF (after printing), and the PlayBook (only, no cables, sleeve, etc.) in the box. Then ship the box. I will receieve the box within 5-7 bussiness days with the repaired PlayBook.

 

I hung up, got the RMA email and am waiting for the PDF (the agent said that the emails were a little slow but I would recieve it within 24 hours).


So that is what has happened so far. Once I sent out the PlayBook and recieve the fixed PlayBook, I will let people know in this post.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1154, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: camera and screenshot not work

Ok, just to update (if anyone cares)

 

The above post was done on Friday.

 

On Tuesday the package came. It comes with everything needed to ship the PlayBook and various legal info. I packed everything up and then realized I still didn't have the PDF. I called and explained the situation on Wednesday, received an apology and was told that they will get the PDF out ASAP.

 

This last Sunday, I still did not have the PDF. I am patient but I want my PlayBook fixed. I have apps that I want to test on it. I called again. The support person was baffled and very apologetic. From what I gathered, when an RMA is created, the info goes into a database. The database is polled and the PDF is generated by the "internal RMA group". The internal RMA group forwards the PDF to the respective RMA agent and they sent it out to the user. A little wacky but I expect there's a reason. RMAs are not a new concept.

 

Regardless, my PDF was never received by the RMA agent. He said he would contact the internal RMA group and get it within a day or so. Earlier today I received the PDF. I will finish packing up the device and sending it out.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1154, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: camera and screenshot not work

Since I already started doing this, I might as well continue.

 

Monday evening (the day of the previous post), I recieved the PDF. I filled this out and packaged up the PlayBook.

I shipped it on Tuesday night and it arrived at the repair facility on Wednesday morning.

 

On Saturday I recieved an email from the RMA agent just checking up with me and informing me that my PlayBook is undergoing repair.

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.
Developer
rcmaniac25
Posts: 1,804
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.2.1.3253, Z10 (STL100-3)-10.3.1.634 Dev OS, Z30 (STA100-5)-10.3.1.634 Dev OS, Passport (SQW100-1)-10.3.0.1154, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: camera and screenshot not work

Ok, last one (a little late).

I stated before that I recieved an email on Saturday (2 weeks ago) stating the PlayBook was undergoing rapair. That Wednesday I recieved it. I was away at that time so couldn't get the box until Friday.

Friday I opened the returned package and it looked brand new. I noticed that the newer PlayBooks have a more-raised power button, which my original did not. The repaired PlayBook had that (I believe the camera and button assembly are on the same board).

Low and behold, the front camera works so everything was done and I'm happy.
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Please use plain text.